VikramK — TomTom Community
Avatar

VikramK

Moderator

VikramK Moderator

About

Username
VikramK
Joined
Visits
7,255
Last Active
Roles
Registered Users, Administrators
Points
10,657
Navigation device
GO PREMIUM
Badges
30
Posts
11,876

Badges

25 Insightfuls5 InsightfulsGuru Professor Expert (In-built navigation)500 Likes250 LikesWisdomApprentice100 LikesFirst Aid25 Likes5 LikesPhotogenicName DropperStarting UPRegular writer Scribe Wordsmith NovelistExpert (RIDER)Expert (GO iOS App)Expert (GO Android App)Expert (Car navigation)First AnniversaryFifth Anniversary

Activity

  • Zwiebelkuchen79
    Hi, on june 10 I posted having the "no maps found" problem on my Go 500 (both basic map on device and Europe map on SD-card corrupted) and asked for a basic map to be attributed to my account. As far as I can see, no action has been taken yet. Could you please intervene and care for a solution to this problem? Thank you very much.
    Zwiebelkuchen79 in "No maps found"
    June 12
  • GTK327
    Hi Vikram,
    Thanks for your earlier response to my problem. Unfortunately I have not made any progress on this in any way at all. You said that the order has not been allocated to my account and to get in touch with our customer service. However with everything I have tried and having seen and tried other suggested approaches I haven't found any way to contact support or customer services in any way.
    Can you give me the a link, email address or some other useable way to contact customer support (in Australia)? DougLap's posts have not helped me.
    Thanks, Gavin (GTK327)
    June 11
    • nabu
      nabu
      https://help.tomtom.com/hc/en-au