GO 5000 Suddenly changed from Lifetime to Subscription

bvitanov
bvitanov Registered Users Posts: 4
Apprentice Seeker
Hi guys,

A couple days ago, I received a notification that my "subscription" for Safety Cameras will expire, which can't be true because I've bought the device with lifetime service for Safety Cameras. At first I thought that, this is kind a bug or a glitch and everything will be fine but yesterday indeed the Safety Cameras were not working and I couldn't report a safety camera.

How it is possible that I received such notification when I have lifetime service?

Best Answer

  • VikramK
    VikramK Administrators Posts: 14,531
    Moderator
    Answer ✓
    Hi @bvitanov
    Welcome to the community! The services on your TomTom have been fixed. Perform a soft reset for the changes to reflect on your side.


    Thanks,
    Vikram.

Answers

  • bvitanov
    bvitanov Registered Users Posts: 4
    Apprentice Seeker
    I think that this is actually GO 5200 but MyDrive Connect detect it for some reasons only as GO 5000. Maybe that's why it suddenly doesn't work.
  • DougLap
    DougLap Posts: 10,116
    Superuser
    Hi @bvitanov

    Look back here on Monday and see what @VikramK has to say after he has checked your units settings on the TT servers and adjusted them if required.

    Doug
  • bvitanov
    bvitanov Registered Users Posts: 4
    Apprentice Seeker
    Hi @DougLap

    ok, thanks for the info. I have this device for years and all the time I had lifetime services.
  • VikramK
    VikramK Administrators Posts: 14,531
    Moderator
    Answer ✓
    Hi @bvitanov
    Welcome to the community! The services on your TomTom have been fixed. Perform a soft reset for the changes to reflect on your side.


    Thanks,
    Vikram.
  • bvitanov
    bvitanov Registered Users Posts: 4
    Apprentice Seeker
    Hi @VikramK

    Thank you very much, everything went well and I've already reported a new mobile camera o:)

    By the way, if I have an issue with calculated route, where I can inform about "error" ?

    Thanks in advance
  • DougLap
    DougLap Posts: 10,116
    Superuser
    Hi @bvitanov

    If you mean a routing error the try using Tomtom Mapshare to advise TT of Mapping issues.

    Doug