Constantly Updating

Regulus Registered Users Posts: 3
Novice Seeker
If the UK maps update constantly stuck updating what would be the issue here?
The file size is 7.5mb, I would like to get this issue resolved please as I have never come across this before. It should be able to complete all updates until there are no more.


  • fergussion
    fergussion Registered Users Posts: 455
    Supreme Pioneer
    soft reset and update on speedy internet wifi
  • Regulus
    Regulus Registered Users Posts: 3
    Novice Seeker
    This is a new product and it had no trouble updating the first initial update of 1.5gb so I don't think internet speed is an issue for a 7.5mb download.

    As for doing a reset, I have held the power button down already until you here the sound and let go as advised by Tom Tom live support and the issue still remains. It might be helpful for diagnosis if it told me the details of the update as users will be left wondering what is happening.

    If it cannot be resolved I'm considering sending it back.
  • YamFazMan
    YamFazMan UKPosts: 21,331
    edited July 30
    Re the GO Discover....
    For the initial registration of the device to your account... You need to connect the device over Wi-Fi....
    For >> ALL << Map Installs & Map updates, the device >> MUST << be connected over Wi-Fi....

    Are you at home with your GO Discover... Connected to a USB port on your PC for a power supply + MyDrive Connect running on your PC ???
    The USB connection will take priority over the Wi-Fi connection....

    To power the device while updating try using something like a Smartphone or a Mains powered USB charger + The Tomtom USB lead)

    Stay Safe... ATB YFM
  • DoubleO
    DoubleO Registered Users Posts: 1
    Apprentice Seeker
    I’m also experiencing this issue with my Go Expert 7. Ever since it was new I’ve updated my UK maps when an update was available and once complete it would state there is still an update available of 7.5mb. When you try to load this update it’s forever updating.. and doesn’t seem to do anything even after 1hr. I’ve tried a soft reset and that hasn’t worked it’s just annoying that the update continually shows but I’m unable to do so. Connected via WiFi at home with a 200mb connection. Any ideas?
  • Lochfrass
    Lochfrass Posts: 18,950
    Delete the map and install the map fresh.
  • Dmer
    Dmer Registered Users Posts: 2
    New Seeker
    As lochfrass says delete uk map then install it again works thank you lochfrass