Unable to save Custom Workouts in MySports

jusnwoop Registered Users Posts: 3
Apprentice Traveler
edited January 24 in TomTom Sports
I have been trying for about 3 weeks now to create and save Custom workouts for my Adventurer.

I am able to create each of the steps, but when I click on "Done" to save the workout, nothing happens.

I have tried creating new workouts and editing old ones that I had created and the same issue happens for both


  • tfarabaugh
    tfarabaugh Posts: 16,948
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, select Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • lampard
    lampard Administrators Posts: 6,006
    Hi jusnwoop,

    Welcome to the Community!

    I can see 5+ custom workouts under 'Planning' tab of your TomTom Sports website. Any changes you make using either the intensity slider or a custom workout are synced to your watch the next time you connect it to your computer or phone.

    Can you see them on your watch under 'Workouts>Custom'? See here: Personalised Workouts

    Cheers, lampard
  • jusnwoop
    jusnwoop Registered Users Posts: 3
    Apprentice Traveler
    Hi Iampard,

    I can see those workouts on my watch, but they were workouts I was able to save from the beginning of this month and earlier.

    Since then I haven't been able to save any new ones or edit those existing ones as nothing happens when I click on "Done" to save them.

  • SuseB
    SuseB Registered Users Posts: 3
    Apprentice Seeker
    Hi jusnwoop, I have exactly the same problem - whether I try to add a workout or copy and change an existing workout, I hit 'done' and get 'not complete' and then it gets lost. I'm trying to do pacing on my runs so the interval section on the watch just doesn't cut it. Just want some help on this!
  • SuseB
    SuseB Registered Users Posts: 3
    Apprentice Seeker
    Hi again ... I May have an answer, kept playing around with it and made sure in the 'steps' column I had the dropdown boxes - warmup, work, rest, cooldown - Then made sure the paces I entered (last columns) were in minutes And seconds. That allowed 'done' to work with a pop-up box 'reconnect watch to synch' (or something like that). So I think if 'done' gets you the 'not complete' pop-up you may have entered something in a format it doesn't like. No idea if that helps or not (or if I'll be able to repeat) but here's hoping :grin:.

    TomTom can we Please just have detailed instructions on website as there is no step-by-step guide to this feature (that I have found anyway).
  • Olegg
    Olegg Registered Users Posts: 1
    Apprentice Seeker
    i had same issue with editing custom workouts.
    Problem was in description - it was copied from other program and there were more then 2 rows. When you editing and it just typing description, then side not allow you to input more then limit, but if you somehow (like i did, copied) put there over some limits it want same it.
    Just cleanup and enter valid descr - couple lines.
    Browser saying when trying to press Done button:

    Error: this.workout.description is undefined
    anonymous/[email protected]https://sports.tomtom-static.com/app/scripts/vendor-versioned-81b17aef.js line 17 > Function:2:172

    Another issue - how many custom workouts can be created?
    I made 5 and can't add another.
  • jusnwoop
    jusnwoop Registered Users Posts: 3
    Apprentice Traveler
    Hi everyone,

    Thanks for your replies. The problem seemed to have been that I had too many custom workouts saved. I have deleted a few and been able to create them again!

  • Mik63
    Mik63 Registered Users Posts: 1
    Apprentice Traveler
    turns out you also need to watch out for any special characters in the name of the workout. "Sian`s Intervals" was not acceptable because of the apostrophe. Shame it doesn't actually tell you what is wrong on the page when it wont save.
  • Momiar13
    Momiar13 Registered Users Posts: 1
    Apprentice Traveler
    Been experimenting a bit and the problem seems to be caused by skipping to a next line by using 'enter' key. Just continue typing your description without jumping line and it will save properly. Not tested max number of custom workouts, this might be an additional solution.
  • Lozzam
    Lozzam Registered Users Posts: 1
    New Traveler
    edited April 22
    hmmmm... got the same problem and I can't make it work even after checking all of the above.

    Wait!... so this is how I fixed it.
    I entered the most basic content and it saved, then I went back in via 'edit' added the detail I needed and it saved it.
    Clunky but I got there in the end, need to go for a run to de stress now.