Frozen Start50

eehawe
eehawe Registered Users Posts: 3
New Seeker
Was updating the maps when I got a 'connection lost with device' told to disconnect and reconnect it. Stayed saying upgrading. I tried a soft reset and it went to the drum roll start screen then froze and no longer connects to pc. Does not show up in device manager, and have uninstalled and reinstalled Mydriveconnect. Still frozen still not connecting. Tried 2 other leads.
Any ideas?

Answers

  • rider1rider
    rider1rider Registered Users Posts: 1,446
    Exalted Pioneer
    check on different computer with mydrive
  • eehawe
    eehawe Registered Users Posts: 3
    New Seeker
    thanks
    Tried mydrive in my newer win11 pc clean install and the tom tom does not connect makes no audible sound on connection - does not show up in device manager at all. It is not detected by pc.

    Is there a hard reset without pc connection?
  • Willy875
    Willy875 Registered Users Posts: 5,927
    Revered Voyager
    @eehawe .

    Try with this FAQ: The navigation device does not connect to the computer. https://help.tomtom.com/hc/en-gb/articles/360013900240-Le-GPS-ne-se-connecte-pas-à-l-ordinateur-MyDrive-Connect-

    Also try to factory reset the device.
  • eehawe
    eehawe Registered Users Posts: 3
    New Seeker
    Tried all of that on the first pc. On the first pc when it went wrong it had already updated to nav4and when I ran 4 more updates for maps,community, etc.. it got to 3% and then said it lost connection. Because it does not connect it does not show in device manager, nor does the computer detect it as the usb is plugged in. This is the same on both pc's.
    I cannot do a factory reset as the tomtom upgrade was interrupred and now just shows the 'TomTom' start screen and no menu is available.
    Basically it was working fine and I should not have upgraded maps!
    There must be an internal connector for initial system load?
    thx anyway