NVA-SD8110: Poor GPS Connection - Are you inside a building?

Jords45_
Jords45_ Registered Users Posts: 2
New Seeker
Hi All,
I've had my Mazda 3 for around 9 months, and updated the live services at the start of the year. Navigation system was all good until a couple of weeks ago where my current location was completely wrong. I've looked at other forums and nothing else has worked out. Now I'm getting a message "Poor GPS Connection, Are you inside a building?" Even when I'm driving on the M25. I'm also getting a error code 14 when attempting to use my live services. If anyone has suffered this problem or knows of anyone that has that would be a massive help.

Thanks

Comments

  • VikramK
    VikramK Administrators Posts: 14,061
    Moderator
    edited April 13
    Hi @Jords45_
    Welcome to the community!
    The SIM card on the Built-In LIVE TomTom gets deactivated or disabled when there is no active subscription(LIVE Services) for 3 years.

    I reviewed your account and I see the previous subscription ended in 2013. More info on our support article

    You can contact our customer service to confirm the SIM status.

    Regarding the GPS signal issue, see the troubleshooting guide on our support article here- https://help.tomtom.com/hc/en-gb/articles/360013900280


    Thanks, Vikram
  • Jords45_
    Jords45_ Registered Users Posts: 2
    New Seeker
    Thanks for the advice Vikram.
    I followed all the steps that you gave me but I am still suffering with the same issue as previously stated. I have spoken to a member of the support team, and followed additional steps that they have provided, but yet again the same result. Do you have any further recommendations?

    Thanks