Tomtom rider 500 Doesn’t connect to my iPhone

Multiwayne29_
Multiwayne29_ Registered Users Posts: 1
New Seeker
edited February 25 in RIDER
Bought a Tomtom rider 500 as it’s one of the latest models
It’s useless . Doesn’t connect to my iPhone
With my drive or not
Phone says it’s connected Tomtom says it connected
Traffic say unable to connect
Messages unable to connect see who’s calling unable to connect
Thought it might be my cheap headset so tried my mates sena still didn’t work apart from my music comes back after a sat nav announcement which it doesn’t do with my headset . Annoying thing is my mate offered me a Tomtom 40 but said no thanks I want a more up to date model I wish had bought his cause everything works with my phone and my cheap headset
So disappointed with my purchase

Comments

  • VikramK
    VikramK Administrators Posts: 14,024
    Moderator
    edited February 25
    Hi @Multiwayne29_
    Welcome to the community! Could you try the advice provided by @kieron in the comment here- https://discussions.tomtom.com/en/discussion/comment/1793674/#Comment_1793674

    Regards,
    Vikram.
  • Haasbroek
    Haasbroek Registered Users Posts: 3
    Apprentice Traveler
    Hi Vikram,

    Ik have the same problem and many many other users. When does TomTom solve this problem?

    Greetings William
  • Jan1411
    Jan1411 Registered Users Posts: 1
    Apprentice Seeker
    It’s easy to say IOS 13 and above are not working properly with the 500 as mentioned above.
    When I pay over €300 for the 500, I want it to work properly. So, come on TomTom!!
    Fix the f…ng problem.
    Thank you, Jan
  • petkostas
    petkostas Registered Users Posts: 4
    Apprentice Seeker
    Have the same problems with Huawei.
  • Varareco
    Varareco Registered Users Posts: 10
    Legendary Explorer
    I will not purchase another TomTom product until you fix the problem with connecting to iOS phones, this problem has been dragging on for years.
  • DougLap
    DougLap Posts: 9,940
    Superuser
    Hi @Varareco

    My iPhones connect to my TT units okay. If you are using an iPhone with IOS13 or later then do not involve the My Drive App in th4 Bluetooth Pairing process as Apple made a change which has stopped the My Drive App connecting. Try the following:-

    Go to Personal Hotspot in Settings on the iPhone and turn the Personal Hotspot On
    Go to Bluetooth in settings on the iPhone and turn Bluetooth On
    Go to Bluetooth on the TT device and Rap Add a phone.
    Tap the TT units name when it appears on he iPhones Bluetooth page and then pair both devices.
    Make sure you have personal Hotspot turned On when connecting to your TT device noting that you will never be asked for the Personal Hotspots Password.

    Doug