I'm frequently getting "No disk space available on your computer for caching" error

FixItDik Registered Users Posts: 5
Apprentice Seeker
I am trying to download the latest EU map (about 8Gb I believe) and I have 12Gb available on my computer. I have my Rider 400 connected and the software recognises it, I have even downloaded the speed camera and community map updates but it starts the map download, after about an hour it starts to flash this black banner across the top of the window (too fast to read) but eventually the message appears and stays.

In full the message says "No disk space available on your computer for caching. Please free up disk space to resume.".

I cleared the cache and started again, cleared up a few more Gb but I am now at 32% downloaded, stuck at that for an hour and the cache-status.xml file has not been updated in an hour.

I try and close the app, reopen it and it resumes the download, sometimes leaping ahead a few % but these past couple of tries it just sits at 32%.

Been trying to download this for 2 hours now but wonder if it hits this "No disk space..." error and that halts the download (even if you clear more space and close the message by clicking the little "X" at the right).

Anyone found a solution or am I just being too impatient and should leave it overnight?


  • YamFazMan
    YamFazMan UKPosts: 21,355
    edited March 2020

    Have you Cleared the MyDrive Connect Cache ???
    The MDC Cache is deleted Manually, the cache does not Auto delete... At 9.13GB for the Full Europe Map... Each download soon mounts up

    With MyDrive Connect running...
    Click on the Cog Wheel Icon Screen top right
    Click on the Downloads Tab
    Empty download folder
    Save settings

    Also if you don't clear the MyDrive Cache ??? You will only re-install any corrupt Map in the Cache again, instead if a Freshly Downloaded & Installed Map

  • FixItDik
    FixItDik Registered Users Posts: 5
    Apprentice Seeker
    Hi YamFazMan,

    Yup I did clear the cache (I think I mentioned that in my description but you are forgiven for not spotting it as I do ramble on). However, since I posted that question I also rebooted the PC (as the first thing the App did was update itself when it started and I hadn't rebooted since - not that it told me to). Since the reboot and a further clearing of the cache it all started again and this time downloaded in about 2 hours and, as I type, is 20% of the way to uploading to the device.

    What I still don't understand is why this error message appears when I clearly had enough disk space? Perhaps the "calculation" to see if there is enough is very rough ("let's allow for twice the size of the file to be downloaded, just in case") - I think that was the main problem (although I am still not sure if it was the upgrade to the new version of MyDrive Connect that was actually stopping the download or if it was this disk space error).

    Hopefully someone else will find this question if they search for that particular error message and see the suggestion to clear the cache as I am sure it is a good one but someone from TomTom should really investigate the required space calculation in the download code...

    Thanks again mate for replying.

  • John-Jay
    John-Jay Registered Users Posts: 749
    Revered Pioneer
    Hi, @YamFazMan ,

    Just searched out this old response, since I was getting this error!

    Have followed your instructions & I'm now downloading a Map-Update!!

    Many thanks!
  • YamFazMan
    YamFazMan UKPosts: 21,355
    You're welcome, glad you're sorted :)

    Stay Safe... ATB YFM
  • mailclerk
    mailclerk Registered Users Posts: 2
    Apprentice Seeker
    I too am getting this message and have tried all solutions with not good results.
    I wonder if I should delete everything and re-down load the entire program?

    Mail Clerk