TomTom 6250 live traffic not working on 2 x devices

Jigadee123
Jigadee123 Registered Users Posts: 3
New Seeker
I have 2 x 6250 with life time traffic updates but neither device is working unless connected to a hotspot although it used to work without having to connect the device. Is anyone able to help ?

Cheers

Comments

  • DougLap
    DougLap Posts: 9,945
    Superuser
    Hi @Jigadee123

    There have been instances of others losing the service via the inbuilt mobile sim due to the contacts on the sim becoming corroded. Before you do this try contacting Customer Support and asking them to check the sims on their system. If they think they should be okay then at your own risk you Ould try the following.

    Very very carefully remove the serial number label from the bottom of the device and so reveal the mobile sim. with the aid of some fine tweezers carefully remove end reinsert the sim a few times and maybe clean the sims contacts with a pencil rubber. When finished really the serial number label to protect the sim and try and see if that resolves the problem.

    There are no customer support phone lines working because so many are working from home because of Covid.

    Try the following:-

    Tap Support at the top of this page
    You then HAVE to Sign in Top Right of next Page. (you have to do this)
    When signed in, and not before, Tap Contact Us bottom right
    Support Box appears and at the bottom with a message option
    Type Contact or Chat in the box
    If Chat is available you should be offered the chance to Tap Live Chat
    If it is Out of Hours for Chat you should be offered an option to message

    If it does not work exactly as described then try another Web Browser.

    Doug
  • Jigadee123
    Jigadee123 Registered Users Posts: 3
    New Seeker
    Hi I have tried following the steps you've recommend with both devices and both still say,

    Tomtom services are temporary unavailable please try again later.

    I'm getting fed up with this I have paid for lifetime traffic but yet they have both stopped working. Is there anyway to resolve this ?
  • Jigadee123
    Jigadee123 Registered Users Posts: 3
    New Seeker
    I have also noticed that both devices have no internet connection ?