New today Professional 620. No traffic or cameras - PLEASE HELP 😞

Ja88erwocky
Ja88erwocky Registered Users Posts: 4
New Seeker
edited January 21 in Devices using Wi-Fi®
Hi all.

I have today bought a Professional 620.

Once set up with my phone (galaxy S20), I have no traffic or speed cameras.

It shows as a Professional 620 in the my drive app, on the web version of my account however, it shows as a GO Supreme 6". Further investigation lists speed cameras as expired, Europe truck map 10.30 as expired and trucker POI as outdated.

I am unable to update any of these without cost.

The main reason I went for the professional 620 to use in my truck is the lifetime traffic, maps, and speed cameras. I am thoroughly disappointed at the moment with this

Can somebody help please?

Thankyou

Comments

  • Willy875
    Willy875 Registered Users Posts: 5,990
    Revered Voyager
    Hi
    Check back tomorrow, moderator @VikramK will review your account and assign the service to you.
  • Ja88erwocky
    Ja88erwocky Registered Users Posts: 4
    New Seeker
    Willy875 wrote: »
    Hi
    Check back tomorrow, moderator @VikramK will review your account and assign the service to you.

    Nice one, thank you.

    I hope so, it's been quite frustrating. Other than that it seems a great device.

    Thanks for the reply
  • VikramK
    VikramK Administrators Posts: 14,046
    Moderator
    Hi @Ja88erwocky

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram
  • Ja88erwocky
    Ja88erwocky Registered Users Posts: 4
    New Seeker
    VikramK wrote: »
    Hi @Ja88erwocky

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram

    Hi,

    Thankyou so much for your help. Outstanding service!

    I have looked and it does say 3 months speed cameras rather than lifetime, and trucker POI out of date.

    Could you take another look please?

    Thankyou again!