New software v21.200.0003 available!

Justyna
Justyna Administrators Posts: 6,563
Moderator
edited January 24 in Devices using Wi-Fi®
Hello all,

We have just released a new software v21.200.0003 for the WiFi and NAV4 devices.

The software release is offered to the following devices:

GO Basic, GO Essential, GO Premium/Premium X, GO Supreme, GO Comfort, GO 520/620, GO 5200/6200, GO Camper, Rider 500/550, GO 52, VIA 53, GO 40, GO 50, GO 51, GO 60, GO 61, GO 400, GO 500, GO 510, GO 600, GO 610, GO 5000, GO 5100, GO 6000, GO 6100, START 40, START 50, START 60, START 42, START 52, START 62, VIA 52, VIA 62, RIDER 40/400/410/42/420/450, Trucker 500/5000/6000

What's new:
  • Bug fixes and improvements
  • This update allows users to select "Power Off" after disconnecting their device from a power source.

Greetings,

Justyna

Comments

  • jfroggyj
    jfroggyj Registered Users Posts: 15
    Master Explorer
    So still no update for the Expert ?
  • Lost_Soul
    Lost_Soul Registered Users Posts: 417
    Supreme Pioneer
    @Justyna

    What's new:
    Bug fixes and improvements

    Do the 'Bug fixes and improvements' include curing the random rebooting, crashing, freezing and other problems numerous users have experienced following the mandatory software update ( V 21.100.0001) at the end of September ?

    Thank you.
  • Teecee259
    Teecee259 Registered Users Posts: 55
    Renowned Trailblazer
    No it doesn't,nor the Dartford Tunnel conundrum.
  • YamFazMan
    YamFazMan Posts: 20,969
     Superuser
    Hi
    @Teecee259
    Teecee259 wrote: »
    No it doesn't, nor the Dartford Tunnel conundrum
    I doubt if a change to the O/S (Navkit) will make any difference to a mapping error....
    You can report a mapping error using the Mapshare reporting tool...
    Here... https://www.tomtom.com/mapshare/tools/new/mapshare/#loc=0.00000,0.00000,2

    Stay safe... ATB YFM
  • Teecee259
    Teecee259 Registered Users Posts: 55
    Renowned Trailblazer
    Hi YamFazMan I feel like I'm going over old ground with this one and I'm not sure how long it takes to correct such an obvious error as the Dartford Tunnel. I'm certainly not the first one to bring this up nor will I be the last. Thanks teecee259
  • JacaMa
    JacaMa Registered Users Posts: 52
    Renowned Wayfarer
    Hi @Justyna
    But you still didn't add the "Skip next stop" neither the "Answer Call" voice commands.
    Stay Safe
    Regards
    JM
  • Lost_Soul
    Lost_Soul Registered Users Posts: 417
    Supreme Pioneer
    @Teecee259

    I bought a Go 6250 in Mid 2019 which was a real disappointment as firstly it would not acknowledge the existence of the Dartford Crossing................coming from Kent back into Essex. I also had issues being sent on circuitous or crazy routes locally which appeared to be partially linked to heights and weight restrictions. I sold it quite swiftly! B)

    I was told that TomTom were aware of the issue but did not have a deadline to cure it, and have since read replies on the forum:

    “We have a ticket raised for this and the investigation is underway. However the team has not been able to identify the root cause for this “.

    I have seen you and other users complaining in recent months so the issue is still ongoing some 2 and ½ years later!

    I hope that Tomtom will resolve this long outstanding issue urgently as this is so important for Truck & other drivers who look to their Tomtoms for guidance on a daily basis as they go about their work ................... but given the length of time that has already passed have my reservations!

    ps I was told by a Tomtom Staff member that some users have reported improvements after a Navkit (Operating Software) upgrade, so these type of issues may be part Map and part Software related.
  • Teecee259
    Teecee259 Registered Users Posts: 55
    Renowned Trailblazer
    @Lost_Soul. I'm of the opinion it needs redone from the ground up. I could take it if they said we are taking the whole thing apart and redoing it and it will take a few months. Every update just it seems just adds new roads, it doesn't seem to correct the ongoing issues. Let's get those fixed first the add new roads as they done seem able to do things concurrently. Just my opinion. I want this new Nds thing to work. Thanks teecee259
  • YamFazMan
    YamFazMan Posts: 20,969
     Superuser
    Hi
    @Teecee259
    This update does not apply to your 7" Tomtom Expert... It's for the NAV4 and the previous Wi-Fi Connected devices....
    I would think there will be further updates/developments released for the GO Discover & GO Expert range of devices at a later date....

    Stay Safe... ATB YFM
  • Teecee259
    Teecee259 Registered Users Posts: 55
    Renowned Trailblazer
    @YamFazMan Hi there thanks for the clarification on that one, as long as the updates seem to clear up the existing errors I'm more than happy to give it a bit more time yet.
  • Lost_Soul
    Lost_Soul Registered Users Posts: 417
    Supreme Pioneer
    @Teecee259

    A re-write would be the ideal solution however I do wonder if TomTom has the capability or inclination to remedy the issues given the limited number of Truck / Camper units that are sold versus the Go 6200 / Go Premium which are their more popular mainstream devices?

    I would imagine TomTom developed new software when they introduced the Go series back in ~2014 and this has been “tweaked” ever since and it was also used as a base for the Truck / Camper version devices (makes sense to have a common operating software) and even possibly the Go Discover / Go Expert?

    My Go Camper routes me on crazy, circular or illogical routes which partially seems to be linked to the weight/width/height restrictions of adjoining roads on a route. On the map when zoomed right in you can see the ends of the limits on these adjoining roads, “overlap” onto the main road, thus causing the device to avoid the main road and consequently often send me round in circles!!!

    This has been ongoing ever since I bought the Go Camper in Mid-2019 and Tomtom is so far unable to correct the issues. :s (Even the very latest [June 2021] Go Expert with the NDS maps is similarly affected).

    As a result of the above I have come to the conclusion the truck / camper devices are flawed to be almost unusable and the Go Premium X is the best compromise at present “for me” B) ; provided I can get it out of its current “pet brick status” by yet another factory reset or putting it into Recovery mode, and reluctantly accept the annoyance of being sent down narrow one track roads and the slow almost unresponsive reaction to menu presses…………. :s
  • Teecee259
    Teecee259 Registered Users Posts: 55
    Renowned Trailblazer
    @Lost_Soul. I feel your pain it does look like the restrictions have been put on with a crayon. These are supposed to be precision applications and as a hgv/camper we cannot take the risk that it is not. I'm really losing all confidence in my go expert. Today I had to put in 10 stops just to make the sat nav go from one end of tha A2 to the other along shooters hill to pekham. The sat nav was continually trying to take me of the A2 because of the problems you have stated. It even tried to take me of it because the bridge I was going over was a low bridge. The errors are creeping up onto the roads overhead.
  • snelleneddy
    snelleneddy Registered Users Posts: 10
    Apprentice Seeker
    Does it fix the computer voices?
  • YamFazMan
    YamFazMan Posts: 20,969
     Superuser
    Hi
    @snelleneddy
    Sorry NO....
    Can you expand on the 'Voice' problem ???

    Stay Safe... ATB YFM
  • snelleneddy
    snelleneddy Registered Users Posts: 10
    Apprentice Seeker
    As with several other people: the computer voices keep silent. The recorded voices work fine. I already tried everything: hard reset + removing computer voices + re-installing computer voices. Soft reset + removing & re-installing computer voices doesn't help too. Already contacted support but difficult to get contact with them.

    I can't understand how it's possible that an expensive item like this (Premium X) has this issue
  • Hejca
    Hejca Registered Users Posts: 12
    Legendary Explorer
    Hi,
    My Premium X stops going to sleep mode after disconnection even if the possibility is selected by the battery settings. When the device is disconnected it is still running till the battery is depleted. Where I can select the possibility to "power off" or "sleep" the device after disconnecting. I always make the "drum reset" after update but it does not help in this case.
  • YamFazMan
    YamFazMan Posts: 20,969
     Superuser
    edited December 2021
    Ho
    @Hejca
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> Battery settings....
    Select... 'Sleep automatically when disconnected from power'
    Have you tried holding in the power button until the 'Power menu' is displayed....
    Stay Safe... ATB YFM
  • Hejca
    Hejca Registered Users Posts: 12
    Legendary Explorer
    Hi
    @YamFazMan
    Thank you for advice. It works now.

    Tap 4Dot (.... Menu) --> Setting --> System --> Battery settings.... 'Sleep automatically when disconnected from power' - This was activated but the system do not want to go to sleep mode when the device was removed form cradle (disconnected). After switch device to "Sleep" from "Power menu" and turn it on again the functionality is back with the new possibility to select between sleep and turn Off.

    Have a nice time

    Jiri


  • SPARFFR
    SPARFFR Bedfordshire Registered Users Posts: 18
    Outstanding Wayfarer
    Hello all
    I'd really like Tomtom to add the current time back on the driving screen. It's no longer available on the Go Expert. This is a problem for trucks without a time display!
    Any one else agree?
  • big
    big Posts: 1,712
    Superuser
    edited January 19
    SPARFFR wrote: »
    Hello all
    I'd really like Tomtom to add the current time back on the driving screen...Any one else agree?

    Absolutely. I don't know of any way to convince them, unfortunately. It's crazy that it's not there -- it's something that's already known.