TomTom lifetime service expiring

Keesuus
Keesuus Registered Users Posts: 2
New Seeker
I own a GO 6" and an older GO 5000. Both with lifetime traffic subscriptions.
With the older GO 5000 that works fine, but with the GO 6" there is no connection (car image with cross below)
What is going on here?






Mod edit: Machine translated (Dutch)

Best Answers

  • Willy875
    Willy875 Registered Users Posts: 6,004
    Revered Voyager
    Answer ✓
    Salut

    Try to reset the device to factory settings.

  • Lochfrass
    Lochfrass Posts: 18,072
     Superuser
    Answer ✓
    Ahhhhmmmm, What kind of go 6" do you have?
    A Go620WIFI has no iternal Sim and needs a Smartpone for the internet connection.
    So there can be an issue on the bluetooth connection.

Answers

  • Willy875
    Willy875 Registered Users Posts: 6,004
    Revered Voyager
    Answer ✓
    Salut

    Try to reset the device to factory settings.

  • Lochfrass
    Lochfrass Posts: 18,072
     Superuser
    Answer ✓
    Ahhhhmmmm, What kind of go 6" do you have?
    A Go620WIFI has no iternal Sim and needs a Smartpone for the internet connection.
    So there can be an issue on the bluetooth connection.
  • Keesuus
    Keesuus Registered Users Posts: 2
    New Seeker
    edited January 13
    I do have a GO 620 Wifi.
    The connection with my phone is present, but there is no traffic information on the TomTom.
    Willy875 suggested a factory reset.
    I'm going to try that first.
    Thanks in advance.
  • Willy875
    Willy875 Registered Users Posts: 6,004
    Revered Voyager
    Hi
    Check back later, moderator @VikramK will review your account and provide you with the service if it is missing?