Can't add new device to MyDrive Connect

Tommo61 Registered Users Posts: 7
Master Traveler
I'm trying to add a GO Essential to MyDrive and have got it connected to my iMac (macOS 10.13.6). The device is online and connected via USB and connected/syncing to myDrive.

MyDrive Connect recognises the connection confirming if I want to add the device when I connect the USB, but it then just loops round the following menu:


Every time I hit continue, the menu just returns with no other options to progress.

On the device under Settings/MyDrive, there are no options to connect the device as it is already logged in and syncing. The only option is to Stop Syncing, which I've tried. I've also reset the device and turned off my Mac firewall, though unlikeley to be an issue as the connection is USB.


  • Tommo61
    Tommo61 Registered Users Posts: 7
    Master Traveler
    I've tried installing on a Windows PC too and get exactly the same issue.
  • Carolmv
    Carolmv Registered Users Posts: 10
    Apprentice Traveler
    edited December 2021
    The exact same thing happens to me in Windows 10 since I updated here

    In Device Manager, TOMTOM does not appear either, which before the update if it came out

    Mod edit: Machine translated (Spanish)

  • Stevon
    Stevon Registered Users Posts: 4
    Apprentice Traveler
    I’m having the same problem after having my lifetime subscriptions added. @VikramK Can you assist please? Thanks
  • VikramK
    VikramK Administrators Posts: 14,066
    Hi all
    Could you try few steps as below-

    1. Disconnect the device from the computer.
    2. Perform a factory reset- Main menu- Settings- System- Reset
    3. Log-in to MyDrive on the device- Main menu Settings- MyDrive
    4. Now connect the device to the computer and open MyDrive Connect.

    Do you see your device listed under your account?

    - Vikram
  • Tommo61
    Tommo61 Registered Users Posts: 7
    Master Traveler
    Full factory reset fixed it. Thanks