Version 2.8 / 2.8.1 GO Navigation app iOS

Jürgen
Jürgen Community Managers, Administrators Posts: 7,308
Community Manager
Release notes for the versions 2.8 and 2.8.1:
  • New Siri Shortcuts available
  • Drive to closest point when planning a route from My Routes *
  • Simplified privacy screen at onboarding
  • Now available in Turkey, Morocco, and Chile
  • Bugfixes & Improvements
This build includes fixes to sound issues on Apple CarPlay.
Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available.

* In the past you could only drive to the starting point of a route from MyRoutes. Now, when tapping "Drive" you also get the option to drive to the nearest point.
f9e45a79k8iz.jpg
«1

Comments

  • loekf
    loekf Registered Users Posts: 64
    Sovereign Trailblazer
    edited October 2021
    Well.... I have to congratulate TomTom that version 2.8 still DID NOT fix the connectivity problems to the traffic servers, when you're on cellular data connection. Though at home, I turned off WIFI and let it run on cellular for a while. You see that after 10 minutes or so, connection to traffic is lost. Cloud connection remains (I've seen that one failing as well, so maybe you fixed something).

    Well.. for some of us, including me (KPN NL, 5G).

    AFAIK, it's related to KPN NL fully supporting IPv6 (among some other providers in the UK and Australia). Apparently, your code doing DNS look ups to TomTom servers is messed up. which surprises me because other apps don't have these issues, e.g. Google and Sygic.

    I already entered a ticket once for this and frankly your support is clueless, useless and helpless (I suspect it's run from an "offshore" location, India ?).

    Please contact me if you need diagnostics/debugging information.

    This problem is present in the iOS app since last year (think March).

    There was mention of a SDK update in 2.8, not sure if this 2.8 build has a SDK version with this fixed.

    Let's call it trying to exceed by incompetence... ?

    PS:

    - VPN still fixes it. Probably because via VPN, IPv6 is not supported, just IPv4
    - There's also a bug that when you turn on VPN BEFORE starting the route, the app crashes. When you switch to VPN AFTER starting the route, it is OK.

    Fix your stuff please, it's ridiculous I'm paying for a non-functional app.
  • sbz
    sbz Registered Users Posts: 17
    Master Explorer
    I updated to version 2.8 on my iPhone 13 running iOS 15.1, but the app will not open. I get a page showing the app log and name with the zig zag background and a progress circle and text reading, "Loading app," but the app never loads. I have an outstanding support ticket on this, but currently no resolution.

    Anyone else have this issue?
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,308
    Community Manager
    sbz wrote: »
    Anyone else have this issue?
    It's mentioned in my announcement:
    Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available.

    As a workaround, quit the app and start it again.
  • sbz
    sbz Registered Users Posts: 17
    Master Explorer
    I had to delete the app from my iPhone and reinstall it to get the app to open. Next, I had to re-download maps. The app opens and works as expected, but all my data - previous destinations - was last when I deleted the app.

    Well, I could wait with out a working app until TomTom released a fix, but there is no assurance that would happen anytime soon. My support ticket correspondence with TomTom made no mention that this was a known issue or that a fix was in the works. (The support experience was frustrating on several levels, but that's another story.)

    I believe TomTom should not have released this update until this start up issue was sorted. Having the app not open is a serious failure! Having new Siri shortcuts, etc., is great, but is moot if the app won't open!

    Maybe I'll let my subscription to Go Navigation lapse and switch to Apple Maps.
  • revitt
    revitt Registered Users Posts: 20
    Master Explorer
    sbz wrote: »
    I updated to version 2.8 on my iPhone 13 running iOS 15.1, but the app will not open. I get a page showing the app log and name with the zig zag background and a progress circle and text reading, "Loading app," but the app never loads. I have an outstanding support ticket on this, but currently no resolution.

    Anyone else have this issue?

    Getting that exact same issue, and just spotted that I have been upgraded to 2.8
  • revitt
    revitt Registered Users Posts: 20
    Master Explorer
    Jürgen wrote: »
    sbz wrote: »
    Anyone else have this issue?
    It's mentioned in my announcement:
    Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available.

    As a workaround, quit the app and start it again.

    How many times to have to restart it, 1, 10, 100. Nothing works including an iPhone restart
  • [Deleted User]
    [Deleted User] Posts: 0
    Supreme Pioneer
    edited November 2021
    @revitt Were you able to fix this by updating iOS to the lastest version released 2 days ago or @sbz workaround?

    If not, it would be best to wait for the patch to be rolled out, please be patient.

    You may try the beta AmiGo app or another app for now, have a great day!

    Stay up to date by checking back in in a few weeks in the forums when a new update that fixes it.

    Shawn
  • Kingo1
    Kingo1 Registered Users Posts: 13
    Legendary Explorer
    revitt wrote: »
    Jürgen wrote: »
    sbz wrote: »
    Anyone else have this issue?
    It's mentioned in my announcement:
    Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available.

    As a workaround, quit the app and start it again.

    How many times to have to restart it, 1, 10, 100. Nothing works including an iPhone restart

    I can recommend to do the app restart without having the phone connected to the carplay device. That works for me. If I have it connected to my car radio It does not work(restarting app) - then it just keeps trying to load.
  • [Deleted User]
    [Deleted User] Posts: 0
    Supreme Pioneer
    yl3qq9rhiyz1.jpeg
    qegtmnph3kye.jpeg

    Hello @Jürgen any plans on replacing the highway icons in the app from the Vignette Icon to the correct Canada highway icons?

    The app shows the right icons on the roads for highways, I want that instead of highway icons when it tells me to go to the highway.

    is this planned?

    they reported my fix in the map reporter as "Fixed"

  • wrtmactt
    wrtmactt Registered Users Posts: 14
    Master Explorer
    sbz wrote: »
    I updated to version 2.8 on my iPhone 13 running iOS 15.1, but the app will not open. I get a page showing the app log and name with the zig zag background and a progress circle and text reading, "Loading app," but the app never loads. I have an outstanding support ticket on this, but currently no resolution.

    Anyone else have this issue?
    Yes. I close the app by swiping up and usually the second time it will open. It is aggravating but eventually opens.
  • wrtmactt
    wrtmactt Registered Users Posts: 14
    Master Explorer
    Problems with Carplay. When I send a route (which is configured on my laptop MyDrive) the route gets picked up on the car. After the first turn, the upper left corner freezes and there is no more spoken instructions. The route still shows on the map. I have a heck of a time quitting the app on the phone. I have even had to turn off the phone and restart to clear the TomTom Go app.
  • Sturmf
    Sturmf Registered Users Posts: 1
    New Traveler
    App doesn´t start after one routing. I have to close the app complete an restart them :# This is a well known problem. I pay for a sevice which doesn´t work
  • Kingo1
    Kingo1 Registered Users Posts: 13
    Legendary Explorer
    edited November 2021
    Seriously "Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available."
    This was written 25th October. I am sorry - but how difficult can It be to fix this...?

    You are aware that currently the app is not working on Carplay for thousands?
  • Superhoops
    Superhoops Registered Users Posts: 26
    Prominent Wayfarer
    Kingo1 wrote: »
    Seriously "Unfortunately a fix to the startup issue could not yet be included with this build. We will release this fix separately as soon as we have it available."
    This was written 25th October. I am sorry - but how difficult can It be to fix this...?

    You are aware that currently the app is not working on Carplay for thousands?

    Its unbelievable isn't it. Its the only app on my phone that doesn't start without force closing it first. I think Tomtom really should employ some software engineers that actually know what they are doing. An app starting up is such a fundamental part of a successful app
  • nigelbbb
    nigelbbb Registered Users Posts: 111
    Supreme Navigator
    The frequent mispronunciations of English place names by computer voice Serena introduced in 2.7 are still present. At best it's irritating at worst it's incomprehensible. Could we please have a timescale on when these errors will be fixed?
  • Annelida
    Annelida Registered Users Posts: 9
    Master Traveler
    nigelbbb wrote: »
    The frequent mispronunciations of English place names by computer voice Serena introduced in 2.7 are still present. At best it's irritating at worst it's incomprehensible. Could we please have a timescale on when these errors will be fixed?

    That's right. The pronunciation problem seems to me to be at its worst after the letter 'r' when an superfluous vowel is introduced; so 'Horsley' becomes 'Horisley' and 'Guilford' becomes 'Guilferi...'

    I've downloaded recorded voice 'Jane' in the hope of an improvement, but not yet tested it. In the meantime, and coupled with the difficulty in even getting TT to start, I was forced to switch to Waze twice recently.

    A timescale would help me to determine my renewal options.
  • CraigS
    CraigS Registered Users Posts: 11
    Legendary Explorer
    Has anyone who has been having problems tested traffic yet on 2.8.1?
  • Richard6666666
    Richard6666666 Registered Users Posts: 20
    Outstanding Wayfarer
    @loekf TomTom 2.81 is working fine on KPN 5G for me with my Iphone 12.
  • CraigS
    CraigS Registered Users Posts: 11
    Legendary Explorer
    Seemed to be working for me today on Three UK, finally.
  • nigelbbb
    nigelbbb Registered Users Posts: 111
    Supreme Navigator
    edited November 2021
    I still have version 2.8 & yesterday morning while driving up from Portsmouth on the south coast of the UK to North Essex I encountered several occurrences of Traffic going offline.

    First I noticed the greyed out car with cross through it at top right of the screen as I was on the A3 a few miles south of the M25 junction where I was caught a few weeks back by Insulate Britain demonstrators closing the intersection but no report of any traffic delay on TomTom. Happily on this occasion there were no problems & heading eastwards on the M25 the Traffic service started working again a few miles later.

    The second occasion was about five miles south of the Dartford crossing where there were speed restrictions & a high volume of traffic which eventually slowed to a crawl. TomTom reported no issues or delays as the Traffic service was offline again.

    I switched to Apple Maps which showed me the extent of the congestion across the Thames & into Essex with a 20 minute delay. I checked occasionally & found TomTom Traffic started working again about 5 miles into Essex but I then switched it off & travelled home with Apple Maps.

    Apple Maps isn't perfect but on the plus side the app including Traffic service is free, the map layout is clear & sharp with good clearly visible figures indicating arrival time, time remaining & miles remaining. The verbal directions are superb & detailed with an extremely natural sounding voice without a trace of mispronunciation. On the downside there is no warning sound when you exceed the speed limit or indeed any indication of current road speed. If this could be fixed I think I would be happy to use Apple Maps all the time.

    This unreliability of the Traffic service with TomTom is destroying the product for me.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,308
    Community Manager
    @nigelbbb
    If you go to our page in the App Store you should be able to pull the 2.8.1 update.
  • loekf
    loekf Registered Users Posts: 64
    Sovereign Trailblazer
    edited November 2021
    @loekf TomTom 2.81 is working fine on KPN 5G for me with my Iphone 12.

    I was slow installing the 2.8.1 updated version. My iPhone 12 and iPad never seems to install updates automatically despite I have it enabled. Always been like that.

    I'm now running TomTom Go for almost an hour at home on KPN 5G and yes, it sticks, traffic is still being updated.

    Would be nice if TomTom acknowledges that they this fixed this instead of putting it under "bug fixes".

    This was a huge bug for more than a year.

    Still wonder what was the exact rootcause and why it is taking them so long.

    EDIT: I had VPN running, so more testing to do.

  • loekf
    loekf Registered Users Posts: 64
    Sovereign Trailblazer
    Update: Yes, I am convinced they fixed it.

    Let WIFI off, went outside, and using cellular data, still traffic.

    Amazing...
  • nigelbbb
    nigelbbb Registered Users Posts: 111
    Supreme Navigator
    Jürgen wrote: »
    @nigelbbb
    If you go to our page in the App Store you should be able to pull the 2.8.1 update.

    Thanks I have now updated to 2.8.1

    I discovered a while ago that the updates automatically get rolled out over a week or two but if you want to force the update you go to the app page in the App Store & then you get the option to update.

This discussion has been closed.