New software version 21.100.0001 for NAV4.5 WiFi devices available for download

VikramK
VikramK Administrators Posts: 13,745
Moderator
edited January 19 in Devices using Wi-Fi®
Hi all,

We've released a new software v21.100.0001 for the NAV4.5 devices that update over the WiFi, is available for download now.

The software 21.100.0001 update will enable "On device renewal" functionality.

Release Notes:

With the "On device renewal" you will receive a message on your device that the speed camera subscription is expired, with the option to scan a QR code in order to renew the subscription.​

The message to renew the speed cameras will be shown under some conditions:​
  1. Speed camera subscription is expired​.
  2. No route planned on device​.
  3. Device is not in motion​.
  4. Message is shown when device is connected to the internet

Below is how the message would look on the device-

s9lafam72bnq.png

After scanning the QR code, you will be redirected to our webshop to finalize and complete the purchase.

If user taps on:

'Close button' (cross on the top right corner):
This will close the "message screen" and you won't receive any more notification.​


'Done button'
The device will display the message in the screenshot below.

6rsfzrr098pe.png


‘Remind Me’ button:
You will continue to get the message.


Drive safe! :D

Thanks, Vikram

Comments

  • Lepre
    Lepre Registered Users Posts: 131
    Sovereign Trailblazer
    Hello,
    I have a GO 5200, now do we have to pay the speed cameras?
    But weren't these services for life? ...
  • DougLap
    DougLap Posts: 9,831
    Superuser
    Hi @Lepre

    Try a Soft Reset and if that does not work then a Factory Reset and if that does not work then advise here and one of the Mods can review your units settings on the TT servers.

    Doug
  • Lepre
    Lepre Registered Users Posts: 131
    Sovereign Trailblazer
    edited September 2021
    Hi DougLap,
    I saw that on Tom Tom's website there is a new software version for GO 5200 v21.100.0001, but the version available for my GO5200 is this: v21.100.0001.411 - like never on Tom's website Tom write one thing and then find another? See the following:
    Release Date: 09/29/21
    Version: 21.100.0001
    Applies to: GO Basic, GO Essential, GO Premium / Premium X, GO Supreme, GO Comfort, GO 520/620, GO 5200/6200, GO Camper, Rider 500/550, GO 52, VIA 53

    Software update that allows users to easily renew an expired service subscription directly on the device.
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Lepre wrote: »
    Hello,
    I have a GO 5200, now do we have to pay the speed cameras?
    But weren't these services for life? ...

    This update does not impact the lifetime subscriptions.
    The message will only be displayed on devices that are sold with limited services.

    E.g:
    1luglurqqou5.png


    Thanks.
  • Lepre
    Lepre Registered Users Posts: 131
    Sovereign Trailblazer
    Good morning VikramK,
    thank you very much for your reply, could you please tell me what this v21.100.0001.411 update is for?
    Thank you very much and have a nice day.
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Lepre wrote: »
    could you please tell me what this v21.100.0001.411 update is for?

    It's the same update I announced above. The .411 in the end is probably an extended numerical version.

    Thanks.
  • wayne26
    wayne26 Registered Users Posts: 279
    Renowned Wayfarer
    Hi VikramK

    There appears to be an issue with my Speed Camera displaying since the update to 21.100.0001.411. Can you please check to see if they are getting sent to my GO 620.

    Thank you in advance.
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Hi @wayne26
    Could you try reinstalling the updates? See steps in my comment link below-
    https://discussions.tomtom.com/en/discussion/comment/1779173/#Comment_1779173

    Regards, Vikram

  • wayne26
    wayne26 Registered Users Posts: 279
    Renowned Wayfarer
    edited October 2021
    Hi VikramK

    I have a GO 620 WIFI, no access to my Drive Connect. I have reset the device, "drum roll, and changed the maps. Are the Speed camera update still pushed out each week.

    Thank you.
  • mnijskens
    mnijskens Registered Users Posts: 7
    Master Explorer
    edited October 2021
    WTF this is a very bad update !! DO NOT Install... My TT550 begins to restart when driving after installing this update !!
    Advised is a reset ! So losing all you customizations etc. Hate this kind of unnessecary updates. Would like a button to switch off updates !
  • nodisclosure
    nodisclosure Registered Users Posts: 12
    Master Explorer
    Nice update, but there are much better updates to make:

    * live updated speed limits on roads with dynamic speed limit through out the day.
    * live updated lane choices on roads with dynamic lane allocation
    * live updated parking options, thus preventing driving to facilities that are already fully occupied.

    * correct drive time! By using maximum official speed limit minus the 5% tolerance.
    * user adjustable maximum driving speed; for use on cars when pulling a trailer. Now you just cannot trust the calculated driving time.

    * corrected toll collect locations and most of all, with direction display on which lane/side the automated toll booths are. (France, Spain, Portugal)

    * correct road markings on the display! (Netherlands) - it is horribly wrong on most "spitsstrook" roads, causing foreign (truck)drivers to drive on the wrong lane.
  • julianb
    julianb Registered Users Posts: 1
    New Traveler
    My Go Premium X has been constantly restarting and giving a lagging GPS postion since taking the latest update, 21.100.0001. Resetting/Restoring via Bios with MyDrive Connect and letting it continue to restart for an hour, may have solved the problem.
  • nodisclosure
    nodisclosure Registered Users Posts: 12
    Master Explorer
    edited October 2021
    @julianb Same here. My Premium X crashes several times for 10-20 minutes when it wakes up or powers on after at least a couple of hours not being used. When there's a route planned it freezes a lot and eventually crashes and sometimes a full OS restart happens too. This renders the device basically useless.

    The only workaround is turning it on and leave it for 15 minutes without any route planned. It will restart 3 up to 10 times until all traffic data is downloaded. Then it is possible to plan a route. It is a little bit quicker when connected to Wifi, but it still very very bad.

    It did not happen right after the update, but only until the first speedcamera updates arrived. It's not clear yet if that is the cause.

    With the previous version 1 or 2 crashes happend too during a drive, but only on very long routes (>500 km). One situation where it is likely to happen is when driving abroad and the mobile datalink changing from one operator to another operator.
    In France, there seem to be a lot of regions without 2G support and then the datalink switches to a connected mobile phone. This also could make it crash sometimes.

    It is unfortunate that TomTom still uses an Android base for their OS, very unstable.

    I will try to reset/clear the device to see of that helps.
  • YamFazMan
    YamFazMan Posts: 20,795
    Superuser
    Hi
    @julianb
    @nodisclosure
    Welcome to the site....
    My GO Premium is OK....
    Some users on the Forum are reporting that logging out of MyDrive in the Setting menu on the device is a beneficial fix for the recent reported laggy interface and random shutdowns....
    Tap 4Dot (.... Menu) --> Setting --> MyDrive....

    I have multiple Tomtom devices, so I have always logged out of MyDrive in the Setting menu on the devices by default (So I can't comment if it's beneficial or not) ???
    Logging out of MyDrive fix for Multiple device using one Account
    See... https://discussions.tomtom.com/en/discussion/comment/1725859/#Comment_1725859
    ____________________

    I also find the Wi-Fi devices are more stable and more responsive in general use when I 'Forget' the Wi-Fi connection....
    Unless you're using a personal My-Fi Hotspot in the car for your data connection, the only other reason for a live Wi-Fi connection is for updating the device....
    I always turn off (Forget) Wi-Fi by default and only login for updates....
    It's no big deal for updates, you only have to enter your Wi-Fi password...
    See... https://discussions.tomtom.com/en/discussion/comment/1763247/#Comment_1763247

    I guess the fewer Data Connections in use on the device, at any one time, the less load on system resources ???

    Stay safe... ATB YFM