iOS app map issues — TomTom Community

iOS app map issues

5welly5welly Posts: 4 [Apprentice Seeker]
I have reporting issues with missing roads in the iOS go app for some time now and is still not been resolved. Depending on how you zoom in on these roads effects if you see them or not. Frustratingly the app will not navigate using these roads. This has not always been the case, only recently been an issue.


  • eddydceddydc Posts: 298 [Exalted Navigator]
    There are plenty of posts concerning this issue and the maps are still out of date despite the many complaints and promises to do it better.
    If the map error has been fixed in map share, you'll be more lucky to find the result using Amigo instead of TT go.
  • 5welly5welly Posts: 4 [Apprentice Seeker]
    It’s frustrating because this is a recent problem. I have been using tt go for some time and it recognised these roads in the past. Not now though.
  • 5welly5welly Posts: 4 [Apprentice Seeker]
    Just tried tt Amigo, exactly the same issue that I have with tt Go.
    Very disappointing.
  • eddydceddydc Posts: 298 [Exalted Navigator]
    5welly wrote: »
    Just tried tt Amigo, exactly the same issue that I have with tt Go.
    Very disappointing.

    Are you sure that the map report has the fixed status?
  • Lost_SoulLost_Soul Posts: 298 [Supreme Pioneer]

    It is a “normal feature” of TomTom to not show roads or name details when on a route and then zoom in as appropriate to show details. I can semi understand this as TomTom tries not to have a cluttered screen just concentrating on the route.

    And if you have reported the missing road and name details on Mapshare then good luck as you will need a lot of patience as typically TomTom takes months even years to correct maps!

    I am not sure what roads you are having difficulty navigating to, but I tried navigating on my IPhone to “Hedges Court” one of the missing Cul-de-sacs in your screenshots. I could not see it on the Go App map at all, but it did appear using the Search tool.

    I can plan a route on my IPhone XS Max on IOS14.8 and Go App 2.7.2 but noticed that for the last few hundred yard the map has “Blue Dotted lines” (never have found a list of what all the map legends are ) and assume the roads could either be “Private or Not Suitable for Traffic”??

    My Go Premium X also shows dotted lines in the immediate area suggesting they are currently designated as Footpaths perhaps?

    Using Amigo I could also plan a route but noted that the roads are all named whereas they are blank at whatever Zoom level in the Go app.

    As you are having problems navigating in both the Go App and Amigo it could be that your phone is the causal link and may need updating / Network reset or if you have not done so already reinstall the Apps but it is strange that both Apps have started to act strangely after recent updates?
  • Shawnloveshorses_161Shawnloveshorses_161 Posts: 180 [Outstanding Explorer]
    Hello Everyone,

    Just wanted to point out that the fixed dosen't mean it will show on the map right now, as it will take time to roll out to everyone.

    As the Go Premium, Comfort, GO Discover and app map updates at different times. GO Discover according to website gets updates every 2 weeks.

    The other 3 times a year, so it depends.

    Just keep reporting it or ask the local citty hall to look into it :)

Sign In or Register to comment.

Who's Online in this Category0