TomTom2 Go LIVE 1000 Blue & Me Fiat Alfa — TomTom Community

TomTom2 Go LIVE 1000 Blue & Me Fiat Alfa

TommyBlueTommyBlue Posts: 3 [Apprentice Traveler]
edited April 18 in Built in car navigation
Hi, I have two brand new boxed Blue Me TomToms now that when pairing to the car accept, then immediately disconnect and will not properly factory reset. Instead of then getting back to the welcome start over again screen the TomTom remains somehow still connected /programmed with Blue Me Fiat/Alfa information but just stalls and faults to a grey car menu icon and will not factory reset clearing the blue Me data and return to a fresh start up screen. It will then not connect or pair up to the car at all and just switches off. I have tried a white screen text 3 quick pushes and got the whirring gears connected immediately to computer waited and then just revert again back to remaining locked into the Fiat or Alfa car and will not give me back the anything other than a grey car icon on the main nav screen. I have also tried pairing back up through the find blue me icon in the connection screen but everytime it fails.
For some reason I cannot get the TomTom to lose whatever it stored into its memory on the first pairing attempt. I have tried removing the battery and main ON off connection ribbon and left for 24 hours but no joy. If I go into connections and turn OFF/Disable bluetooth then the tomtom works fine as a basic model for road use.

This has happened 3 times now all with brand new boxed unused tomtoms and on different cars. I have factory reset and paired up then an older tomtom2 blue me's to the same cars with no problem.

Is there anyway of getting through to a TomTom engineer technician. These TomTom Blue & Me's are an expensive item at £300 each. Map updates and LIVE services all updated with no problem apart from one which gave me the LIVE services but no initial first map update. These are not someone elses faulty units and doubtful anyone is selling them because they know they are faulty unless TomTom know of a batch fault from the serial numbers which are one TG and two that are TQ.........I am at a loss here and have fitted probably a couple of hundred over the last few years to Fiat and Alfas so not sure why all of a sudden this problem is arising. Certainly cannot afford to continue buying and installing until this is resolved now.

If I can just get back to a proper factory reset and everything else removed it would be a start to try again and if I can't then again it helps me believe no one else has tried to off load faulty new old stock.

Best Answer

  • TommyBlueTommyBlue Posts: 3 [Apprentice Traveler]
    Accepted Answer
    Thanks I tried a LIVE chat but it was with a ROBOT and just kept telling me to do a factory reset.......not sure where email is for customer care but that would be better than electronic robotic LIVE chat......maybe the robot needs a factory reset too.

    Help me where I find email for customer care please

Answers

  • rider1riderrider1rider Posts: 1,211 [Exalted Pioneer]
    live chat tomorrow or send email to their customer care
  • TommyBlueTommyBlue Posts: 3 [Apprentice Traveler]
    Accepted Answer
    Thanks I tried a LIVE chat but it was with a ROBOT and just kept telling me to do a factory reset.......not sure where email is for customer care but that would be better than electronic robotic LIVE chat......maybe the robot needs a factory reset too.

    Help me where I find email for customer care please
  • TommyBlueTommyBlue Posts: 3 [Apprentice Traveler]
    edited October 4
    Well 6 months on and almost daily emails with TomTom customer support just forget it as despite offering to send back brand new corrupted TomTom2 blueandme (£3000 worth) they just say they are working on it and have tagged the issue. Frankly whether it is they just do not care or I believe just do not have the technical ability to resolve they just keep either ignoring the issue or telling me to do a redX reset that just does not work.
    I am now changing over my fleet to google maps and having iPhones instead..
Sign In or Register to comment.

Who's Online in this Category0