Go Camper won't install Europe Camper map - download fails, map corrupt — TomTom Community

Go Camper won't install Europe Camper map - download fails, map corrupt

When I tried to update my Go Camper for the latest Europe Camper map a couple of weeks ago it failed - download stalled at 43%. This left it with no maps installed and I eventually managed to install a UK map so that I could try and make progress but despite many attempts the Europe Camper map would not get beyond 43% downloaded.

Support identified that there was a corrupt map and instructed me to delete it with the MyDrive Connect app but any attempt to download a fresh copy fails at exactly the same point as before. Watching the download, I see the download reaches 54%, pauses for 2 minutes then jumps back to 43% downloaded, stays at 43% for around 30 minutes then says the download has failed (Servers are busy). This takes me back to a corrupt map and around we go again. Deleting a map normally takes multiple attempts - currently on 10+ for the current corrupt map.

Downloads have been tried over USB both with the download initiated from MyDrive Connect and from the device and also over WiFi but the failure is the same every time. Downloading, installing and deleting other maps works (tried Iceland – a small map, and USA – approximately the same size as Europe Camper) so the problem seems to be limited to the Europe Camper map. Also tried installing to an SD card – also fails in the same manner (54% downloaded, then falls back to 43%, etc).

Best Answer

  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    Accepted Answer
    Problem solved! I lost count of the number of time I tried and failed to install this map but believe it was over 50 attempts. On the last try I tethered my mobile phone until all my data was gone then switched back to WiFi (changing the SSID to match that on my phone so the TomTom device would think it was still on the same network). I doubt either of these steps were the magic step that solved the problem.

    Thanks to Willy875 and DougLap for your suggestions.

Answers

  • Willy875Willy875 Posts: 2,926 [Exalted Pioneer]
    In Wi-Fi you do the GPS download well connect to a mains charger and not GPS connect to the computer?
  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    When downloading over WiFi the device is connected to a charger not the PC. That is how it originally failed and subsequent attempts by this method have also failed.
  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    More testing: Europe Central & East map will install (and can be deleted without problem) but Europe [non camper] will not install - identical symptoms to Europe Camper. Not sure what this means - is there an issue with the full maps of Europe or is it just that those are the two largest maps and there is a limit I am hitting? The device shows over 10Gb of free space and the map is 8Gb and it also fails on a new 32Gb SD card so it is not lack of space but maybe some other limit?

    Despite chasing, the support team do not respond - last heard from them on Tuesday despite chasing - and there is no phone support (due to Covid). It is a disgrace that after 18 months a technology company has not been able to sort things so their phone support allows their team to work from home. Most businesses had that fixed in a couple of weeks.
  • DougLapDougLap Posts: 9,115
    Superuser
    Hi @Malcolm_R

    I have flagged this to @VikramK to see what he maybe can suggest after he has reviewed your units Logs on the TT servers particularly as you have tried several times and you say you have had a message suggesting you had or had a corrupt map on the unit which Support suggested you delete using My Drive Connect and you cannot now reload new version..

    When you installed the 32gb card did you format it on the GO Camper for maps because that is needed before maps will be added to it. If you have nothing on that card then I would be tempted to remove the card and see what happens. If that makes no difference then I would do a Full, not Quick , format of the Micro SD card to Fat32 and reinsert it in the device and Format it for maps there.

    Doug
  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    Thanks. The card was formatted on the device and then selected for map storage (not routes). The card is currently empty - removed to PC, files deleted then inserted back in the device and reformatted.

    Just spoken (live chat) with support again and they reckoned "try it again" but could not suggest why they expected it to work when it had failed 50 times before - it failed again. Just waiting for it to move from "43% downloaded" to "failed" then I can delete the corrupted map. Last time deleting the corrupt map took continuous attempts over 1 day as each try takes 10-20 minutes before the "servers are busy" message. Interestingly when I try another map eg Central Europe, and delete it, the map is deleted in seconds
  • Willy875Willy875 Posts: 2,926 [Exalted Pioneer]
    Try to format the Sd with the computer then insert the Sd again in the GPS so that it formats it again.
  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    I have previously tried that but the result is always the same for the Europe Camper map but other maps will install to the SD card.

    Whether I download over WiFi or connected to the PC and if connected to the PC whether I start the download from the MyDrive Connect app or from the device, whether I install to the device memory or the SD card the result is the same: 53% downloaded (I think I said 54% above), jumps back to 43%, waits 20-30 minutes and displayed a message that the download failed. Also other maps will download again WiFi or USB, main memory or SD Card/from the app or from the device. Working maps are UK and Republic of Ireland, Iceland, USA Camper, Central Europe - all are deleted apart from the UK map. The only other map which fails is the full map of Europe ie non camper which is obviously very similar to the one I want - Europe Camper.
  • Malcolm_RMalcolm_R Posts: 6 [New Seeker]
    Accepted Answer
    Problem solved! I lost count of the number of time I tried and failed to install this map but believe it was over 50 attempts. On the last try I tethered my mobile phone until all my data was gone then switched back to WiFi (changing the SSID to match that on my phone so the TomTom device would think it was still on the same network). I doubt either of these steps were the magic step that solved the problem.

    Thanks to Willy875 and DougLap for your suggestions.
Sign In or Register to comment.

Who's Online in this Category0