Map update not possible — TomTom Community

Map update not possible

Hi all!

For several weeks my Go 620 Wi-Fi announces that there is a new map update available. But every times I try to start the update it gives me an error messag e ('Ups Es ist ein Fehler aufgetreten. Bitte versuchen Sie es noch einmal.'). This message appears initially, before the download starts. Is there any solution for this problem?

Thanks in advance!


  • DougLapDougLap Posts: 9,127
    Hi @DocMorpheus

    Have you got an extra memory card fitted and formatted for Maps on the device. Also what free memory do you have.

    If you try to load another map does that work if so you could, if you have 2 or more maps on the device, try deleting the existing map and then reloading it.

  • DocMorpheusDocMorpheus Posts: 6 [Novice Seeker]
    Hi @DougLap!

    Thanks so far! No, I don't have a SD card in my device.
    So I started downloading another map, that worked so far. Afterwards I changed to this new map. But when I tried to delete the first map, the same error message appeared again, it whas shown when updating it.
    Do you have any idea?
  • DougLapDougLap Posts: 9,127
    Hi @DocMorpheus

    I assume the map you currently have on the device but want to update works normally at the moment if selected?

    Try a Soft Reset. This is a good thing to do after any updates etc.

    If that does not work then go to the Tomtom My Drive Website and log into your account. Then check that your My Places and My Routes etc are all saved there so will sync back onto the device after a Factory Reset. If you have any Routes created on the device and saved there, they will have a Solid Shafted Arrow against them in My Routes, then these do not sync back t your account and so you need use a Small Micro SD Class 10 card to export them for the unit so you can restore them after.

    If your data is saved in your My Drive account then:-

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    After the Reset you will have to set the unit up again as you did when first taking the unit out of the box.

  • DocMorpheusDocMorpheus Posts: 6 [Novice Seeker]
    Hi again!

    Again thank you!
    Now I performed a soft reset and also a complete recovery of the device. After the latter, I had to update the software, which worked quite well. But still the maps update ends in always the same error message.

  • DougLapDougLap Posts: 9,127
    Hi @DocMorpheus

    Okay lets see if @VikramK or @lampard have any suggestions. Look back here tomorrow to see what they say.

    Should they suggest that you contact Customer Support then try the following.

    Try the following:-

    Tap Support at the top of this page
    You then HAVE to Sign in Top Right of next Page. (you have to do this)
    When signed in Tap Contact Us bottom right
    Help Box appears and at the bottom is a message option
    Type Contact or Chat in the box
    If Chat is available you should be offered the chance to Tap Live Chat
    If it is Out of Hours for Chat you should be offered an option to message

    If it does not work exactly as described then try another Web Browser.

  • DocMorpheusDocMorpheus Posts: 6 [Novice Seeker]
    Thanks so far!
Sign In or Register to comment.

Who's Online in this Category1