TomTom GO not running on Tablet — TomTom Community

TomTom GO not running on Tablet

ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
Up to early Aufgust, I had Tomtom Go running on Samsung Galaxy Tab A (2016) tablet like a charm. With the newest update, Tomtom crashes when I start the app, even after resetting the device to factory settings and only Go installed (3GB internal memory free, 120GB of fresh formatted SD available).

What can I do? If the Tab A is too outdated, which new 7" tablet is compatible to TomTom Go?


  • lampardlampard Posts: 5,703 Moderator
    Hi @ralfsteck

    Welcome to the Community! Can you provide us with the Android version and GO App version installed on your Tablet?

    Best, lampard
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    it's on the recent official versions, Android 5.1.1 and TomTom Go 3.2.12. Everything was fine up to an update around August 8./9th.
  • lluiscnlluiscn Posts: 40 [Renowned Wayfarer]
    Probably the problem sucks the Android version.
    This tablet can be upgraded to version 8.1.0
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    I see, there are different Tab A 2016. Mine is the SM-T 280 Tab A 7.0 2016.

    There is an Android 8 upgrade for the Tab A 10.1 2016 but (according to the software upgrade in the tablet) nothing new for my tablet.

    Anyway, TomTom states "Adroid 5 and higher" as prerequisite.
  • MUPMUP Posts: 421 [Supreme Pioneer]
    edited August 17
    ralfsteck wrote: »
    Anyway, TomTom states "Adroid 5 and higher" as prerequisite.
    May be it's wrong.
    For AmiGO TT had set the min version to 6.
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    I can only believe what TomTom says. And it ran smoothlyx until a few days ago.
  • lampardlampard Posts: 5,703 Moderator
    Hi @ralfsteck

    Thanks for confirming! I've sent it to my team for the investigation, do you happen to know what was the last working version on your tablet?

    Best, lampard
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    As I run every update, the version before 3.2.12 :-)
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    no new ideas?
  • BiomacBiomac Posts: 0 [Apprentice Seeker]
    edited September 16
    I have two tablets: a lenovo Tab 7 running Android 5.0.1 and a huawai mediapad 7" running android 6

    My phone (sony Xperia premium running android 9) works perfect.

    I tried a lot of things (clearing SD card, removing SD card, reinstall program, rebooting tablet with manufacter-settings - no success, the app stops working while starting up on both tablets - I have been using the Lenovo device for the past 3 years with no problem, but after the last update it crashed, the same go's for the Huawai (which is my mothers)

    This discussion was created from comments split from: TomTom GO stopped working!.
  • eribajantjeeribajantje Posts: 2 [New Seeker]
    edited September 21
    GO app does not work on my Lenovo Tablet TB3-710F. In 2019 the app worked well on the same tablet, now the app stops automatically, I can't get the app working

    Mod edit: Machine translated from Dutch!
  • eribajantjeeribajantje Posts: 2 [New Seeker]
    Heeft er dan niemand een oplossing
  • TrevorCSRTrevorCSR Posts: 2 [Apprentice Seeker]
    The updated app does not work on my Samsung SM-T280. I have two of these, one I have prevented from updating, so the old app still works. But the other does not work with update.
    Likewise it does not work on the Chinese in car unit that has Android 10.
  • ralfsteckralfsteck Posts: 7 [Apprentice Traveler]
    @TrevorCSR which is the latest working version for you? Maybe I can rollback to that?

    @lampard Any news? I NEED a working Tomtom App in a 7" tablet, preferrably on my Samsung Galaxy Tab A (2016).
  • pdijkman62pdijkman62 Posts: 4 [Apprentice Traveler]
    edited October 31
    Same problem here:
    Tablet: Lenovo TB-8504F
    Android: 8.1.0
    Kernel versie: 3.18.71
    Tomtom: 3.3.14(4187)

    After latest update tomtom go crashes after startup.

    Why is there no answer from TomTom?
  • Crusader3020Crusader3020 Posts: 32 [Renowned Wayfarer]
    I have a Samsung Galaxy Tab S2 8" with Android 7.
    This was working perfectly prior to the 3.3.14 upgrade, but now also crashes pretty much straight away after loading.
  • pdijkman62pdijkman62 Posts: 4 [Apprentice Traveler]
    Still NO answer from TomTom?
  • Willy875Willy875 Posts: 2,937 [Exalted Pioneer]
    Try to install the application with the install button on the play store.
  • pdijkman62pdijkman62 Posts: 4 [Apprentice Traveler]
    Did it allready, no effect!
  • pdijkman62pdijkman62 Posts: 4 [Apprentice Traveler]
    I repeat: NO ANSWER FROM TOMTOM!!!!!!
    As usual!
  • Naviuser67Naviuser67 Posts: 3 [Apprentice Traveler]
    I just don't get why TomTom won't cater to the thousands of people with Chinese car head units with Android. It worked great until TomTom deliberately made it stop working.
    NOBODY buys PNA's anymore, they either use a (free) app on the phone and if they're lucky, it's Android Auto compatible, or they buy an Android Headunit to run their navi app
Sign In or Register to comment.

Who's Online in this Category1