Why my TT go expert 7inch "freeze" sometime....

Bpnav6250
Bpnav6250 Registered Users Posts: 23
Legendary Explorer
edited September 2021 in Devices using Wi-Fi®
Why my TT go expert "freeze" sometimes when I'm trying to search something?
Then screen goes dark, then restart...
I'm using all accessories from the box.
I think its a software problem bcs another friend of mine have same problem with his TT expert(smaller one) , also I had same problem with my old 6250 TT.

Also another thing whats bothering me is that after I close my device before arrival to destination, next day when I start it, route is gone, I have to imput destination again. This not happening all the time, but its annoying

Another thing : why I'm seeing USA poi's and destination if I'm in Europe (device was bought from an UK store)?

Why I don't have an option when after I chose a destination to decide if that destination to be added as final destination or added as intermediar stop. Now can be added only as intermediar, you have to go and manually reorder stops.

New TT expert its super, much much faster routing then my 6250.

Answers

  • Lochfrass
    Lochfrass Posts: 18,059
     Superuser
    Have you rested the above situations with and without internet connection?

    Do you mostly set the devices to sleep moder or do you shut them down?
  • Bpnav6250
    Bpnav6250 Registered Users Posts: 23
    Legendary Explorer
    I've notice everytime was happened this "freze" followed by black screen and a quick restart(not a drum restart), device was connected to Internet via WiFi
  • Bpnav6250
    Bpnav6250 Registered Users Posts: 23
    Legendary Explorer
    Usually I just unplugged the device. Loosing route happens both ways, shut down, or sleep