App MyDrive drains the battery in few hours

lucadelo
lucadelo Registered Users Posts: 4
Apprentice Traveler
This morning I found my Android Phone really hot with MyDrive App consuming 20% of the overall battery. And I didn't even open the app...
So I had to uninstall the app to avoid a complete drain of my phone battery! terrible behaviour.
Is this happened only to me?
How do I know when the problem will be fixed? Rider 550 uses that app for traffic and radars!
Tagged:

Best Answer

  • kieron
    kieron Posts: 524
    Superuser
    Accepted Answer
    Hi there @lucadelo -

    You don’t require the MyDrive app installed on your Android phone to receive traffic and speed camera data. Since the Bluetooth/MyDrive data pairing issue regarding iOS 13+ operating systems on Apple phones, I have directly paired my Rider 500 to my phone and receive traffic/camera data perfectly.

    1. - Delete the MyDrive app on your phone
    2. - Delete old Bluetooth pairings of the gps on your phone
    3. - Connect the gps to your phone over Bluetooth through the standard way
    4. - Install the MyDrive app -
    5. - DO NOT pair your gps via the MyDrive app
    6. - Have personal hotspot on your phone turned ON.
    (Some of the above information reproduced by JURES, another forum contributor)

    I personally just use the MyDrive app (signed in to your account) just to send routes/destinations to my Rider - but -
    JUST DON’T PAIR your gps with the MyDrive app!

    What this entails on users particular devices operating under iOS 13+ is that they have currently lost the ability to receive stable text/phone call information on their gps navigation screen.

Answers

  • kieron
    kieron Posts: 524
    Superuser
    Accepted Answer
    Hi there @lucadelo -

    You don’t require the MyDrive app installed on your Android phone to receive traffic and speed camera data. Since the Bluetooth/MyDrive data pairing issue regarding iOS 13+ operating systems on Apple phones, I have directly paired my Rider 500 to my phone and receive traffic/camera data perfectly.

    1. - Delete the MyDrive app on your phone
    2. - Delete old Bluetooth pairings of the gps on your phone
    3. - Connect the gps to your phone over Bluetooth through the standard way
    4. - Install the MyDrive app -
    5. - DO NOT pair your gps via the MyDrive app
    6. - Have personal hotspot on your phone turned ON.
    (Some of the above information reproduced by JURES, another forum contributor)

    I personally just use the MyDrive app (signed in to your account) just to send routes/destinations to my Rider - but -
    JUST DON’T PAIR your gps with the MyDrive app!

    What this entails on users particular devices operating under iOS 13+ is that they have currently lost the ability to receive stable text/phone call information on their gps navigation screen.
  • lucadelo
    lucadelo Registered Users Posts: 4
    Apprentice Traveler
    Thanks Kieron! That's really a fantastic advice! =) It works and I'll use it!

    Frankly speaking, and I am an old TomTom user (and lover) with a 10 years old TomTom One still working, I'm really disappointed with the rider 550. TomTom Software is full of bugs and the perfection of old devices is still far away.
    Then I have issues with charging the device with its dock, but that's another open ticket...
  • kieron
    kieron Posts: 524
    Superuser
    edited July 2021
    Hi @lucadelo -

    Glad to hear it was useful - safe riding and take care. B)
  • Niel_Knight
    Niel_Knight Registered Users Posts: 11
    Master Explorer
    lucadelo wrote: »
    Thanks Kieron! That's really a fantastic advice! =) It works and I'll use it!

    Frankly speaking, and I am an old TomTom user (and lover) with a 10 years old TomTom One still working, I'm really disappointed with the rider 550. TomTom Software is full of bugs and the perfection of old devices is still far away.
    Then I have issues with charging the device with its dock, but that's another open ticket...

    Hi Lucadelo. I've just installed my new Tomtom 500 on my motorbike. The docking port does not work! Either when wired into the lights as Tomtom suggest or directly to the battery. It charges fine via USB and mains electricity. I've got a ticket in with Tomtom about it. Reading this forum, I think it's a common problem. I almost certain to send mine back and get a refund. ... if Tomtom ever respond to my ticket!
  • lucadelo
    lucadelo Registered Users Posts: 4
    Apprentice Traveler
    Hi Lucadelo. I've just installed my new Tomtom 500 on my motorbike. The docking port does not work! Either when wired into the lights as Tomtom suggest or directly to the battery. It charges fine via USB and mains electricity. I've got a ticket in with Tomtom about it. Reading this forum, I think it's a common problem. I almost certain to send mine back and get a refund. ... if Tomtom ever respond to my ticket!

    Hi Niel_Knight, I had the same problem with the docking. I opened a ticket for it and I sent back to tomtom (tomtom paid shipment) and i had it back a new one working. I know it's annoying but it worked for me.

    This before having the MyDrive app problem that is still there, the app is still in version 2.16.0 since 5 july 2021!!