GO 520 just stopped working

Loobyloo
Loobyloo Registered Users Posts: 6
Apprentice Traveler
edited December 2021 in Devices using Wi-Fi®
After one of the iOS updates, my GO 520 just couldn't link to live traffic updates, this was annoying enough as TomTom and Apple just batted the blame back and forth to each other. Now the Tom Tom has just stopped working completely and won't turn on with the power button even when fully charged. The help video doesn't help at all... hasn't got the same reboot button. I am loathe to pay for a brand new sat nav device when nothing has happened to mine to produce such disappointing performance, it's pristine.

Comments

  • DougLap
    DougLap Posts: 9,959
    Superuser
    Hi @Loobyloo

    If you have an iPhone or similar mains charger pug that will take the USB cable then use that to charge the GO520 for 2 hours plus. When you have done that then try Press and Holding the ON/Off button in for circa 20 seconds plus until hopefully you hear a Drumroll sound then let the button go.

    Doug
  • Loobyloo
    Loobyloo Registered Users Posts: 6
    Apprentice Traveler
    Thank you Doug, I'm sure I have the relevant plug somewhere. I shall try that and let you know how I go on... any idea about a fix for the traffic please? (IF I happen to get the drumroll!)
    Lou
  • Loobyloo
    Loobyloo Registered Users Posts: 6
    Apprentice Traveler
    Actually Doug... it's working already again now - THANK YOU... might have been the charger plug. I'm using a new one. Maybe the old one was defunct. the screen has come on again, but I'll leave it plugged in for at least 2 hours... still could do with any steer on the traffic if you're able please... thank you so much, you've been a massive help already
  • DougLap
    DougLap Posts: 9,959
    Superuser
    Hi @Loobyloo

    If you were pairing your GO520 with the My Drive App included in the procedure then completely delete the Pairings form both the Phone and TT unit then turn both Off and On again.

    Once you have done that go to Settings on the phone and turn on Personal Hotspot then go to Bluetooth on Settings on the iPhone then Turn the TT unit on and Press Add a phone in Bluetooth . You should now get a pairing and at no time will you be asked for the Personal Hotspot Password neither will it appear on the TT unit as connected to its Wifi.

    At all times when using the iPhone with your TT unit you must have the Setting in personal Hotspot turned On other wise the connection will be lost.

    Once you have got the unit going then if necessary we can ask one of the Mods to look at your units settings on the TT servers re Traffic.

    Doug
  • Loobyloo
    Loobyloo Registered Users Posts: 6
    Apprentice Traveler
    Hi again Doug... just about to try this... what is 'mods' please?
    Sorry to be dim!
    Thanks,
    Lou
  • Loobyloo
    Loobyloo Registered Users Posts: 6
    Apprentice Traveler
    I've just worked through those instructions Doug... they are pretty much what I've done before, and as previously, the TT links to traffic info while I'm in the house ... but once I get on the road, it ceases. I have not tried the TT on the road yet after following your instructions. Just downloading some updates too, so I'll let you know how I go on. But still unsure what 'Mods' are... moderators? Thanks again, really appreciate your clear instructions... Lou
  • DougLap
    DougLap Posts: 9,959
    Superuser
    Hi @Loobyloo

    Mods are the TT employees who view this forum and can check back on the TT servers etc. Lets u know how you get on with the Pairing as suggested.

    Doug
  • Loobyloo
    Loobyloo Registered Users Posts: 6
    Apprentice Traveler
    Doug, you've been absolutely BRILLIANT - my TomTom is now back to working properly again. Fully functioning and with traffic alerts etc, I am so relieved since I am about to need it more than ever, travelling to many work events over the next few months. Can't thank you enough, thank you thank you thank you... Lou
  • DougLap
    DougLap Posts: 9,959
    Superuser
    Hi @Loobyloo

    Glad you are sorted. Just be sure to have Personal Hotspot turned on in Settings when your phone is Bluetooth linked to the GO520.

    Doug