Can't log in to MyDrive - help! — TomTom Community

Can't log in to MyDrive - help!

CTCTCTCT Posts: 22 [Master Explorer]
Hi,

This regards my dad's unit and account, he has a GO620. The problem is that his email address was erased by the provider (due to them not providing a mail service anymore) and thus he can't log on to that mail server. This was also the address used in his MyDrive account, hence he can't log on to MyDrive. We have tried setting up a new account with a new email address, but get the message "We cannot create an account using this email address".

I spoke to support, who told me to reset the device, and that would erase the old MyDrive account so we could create a new one with the correct email address. This didn't work.

Thankful for any urgent help, we need to use it in the morning.

Best Answers

  • YamFazManYamFazMan Posts: 19,921
    Superusers
    Accepted Answer
    Hi
    @CTCT
    Are there any none standard characters used in the email address ???

    ATB YFM
  • CTCTCTCT Posts: 22 [Master Explorer]
    Accepted Answer
    We fixed it by using another email address without underscore, and that worked. Don't know if that was the problem, but if anybody has the same issue, you could try that. :)

Answers

  • YamFazManYamFazMan Posts: 19,921
    Superusers
    edited July 28
    Hi
    @CTCT
    After you reset the GO 620 Using....
    Tap 4Dot (.... Menu) --> Setting --> System --> Reset Device

    Did you log into MyDrive on the GO 620 Using...
    Tap 4Dot (.... Menu) --> Setting --> MyDrive... Log in using New Email & Password

    Stay Safe... ATB YFM
  • CTCTCTCT Posts: 22 [Master Explorer]
    YamFazMan wrote: »
    Hi
    @CTCT
    After you reset the GO 620 Using....
    Tap 4Dot (.... Menu) --> Setting --> System --> Reset Device

    Did you log into MyDrive on the GO 620 Using...
    Tap 4Dot (.... Menu) --> Setting --> MyDrive... Log in using New Email & Password

    Stay Safe... ATB YFM

    Hi, thanks for your answer! Yes, I've tried this. I don't get the option to "log in using new email" but rather "create an account", but when I do this with his new email and a password, I get the "We cannot create an account using this email address".
  • YamFazManYamFazMan Posts: 19,921
    Superusers
    Accepted Answer
    Hi
    @CTCT
    Are there any none standard characters used in the email address ???

    ATB YFM
  • CTCTCTCT Posts: 22 [Master Explorer]
    Only an underscore ( _ ), does that matter?
  • CTCTCTCT Posts: 22 [Master Explorer]
    Accepted Answer
    We fixed it by using another email address without underscore, and that worked. Don't know if that was the problem, but if anybody has the same issue, you could try that. :)
  • YamFazManYamFazMan Posts: 19,921
    Superusers
    Hi
    @CTCT
    You're welcome, glad you're sorted :)
    To help others in the community with similar problems....
    If my reply answered your question ???
    Then on my Reply... Please answer 'Yes'
    To... Did this answer the question? 'Yes'< >' No'

    Stay Safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category0