Go 50 won't start past Tom Tom logo — TomTom Community

Go 50 won't start past Tom Tom logo

Go 50, did the update after a few years not using it, that went fine and I was able to use the gadget, turned it off to charge, now it won't start.

Shows the Tom Tom logo does some of the drums but sounds like it cuts off just before the end, then I get the logo and that's all she wrote.

Have followed all the posts on here on how to do a soft reset, how to rescue this and that but can't get it to do anything other than holding the power button down for 25 - 30 seconds which cycles it on and off.

Answers

  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    edited July 28

    I'd love to tell you if it did but clicking that link directs me to a page, then immediately back to the front page for this community, and I haven't managed to read more than the first line of the article. Zendesk doing zendesk things I expect. Thanks for trying though, I appreciate it.

    edit - is there any way to see if this is charging when powered off? No lights or anything on it. Left it plugged in to my desktop overnight but no idea what the battery status is.
  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    nabu wrote: »

    Thanks, I did watch that video but am reluctant to start ordering parts or dismantling anything as it did work long enough to do several updates, restart a few times and only after a couple of hours of being okay did it start this up.

    The drums not completing their little roll, cutting out a beat or two before the end before going back to the Tom Tom logo had me hoping it was a software issue but is there any other way to reset the unit other than the one's detailed on here (power on, hold power button til white text appears, tap 3 times etc. - I can't get the white text to appear).
  • nabunabu Posts: 16,890
    Superusers
    press the power button for + / _ 30
    seconds
  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    nabu wrote: »
    press the power button for + / _ 30
    seconds

    Done that - when powered off, holding the power button, it lights up with the Tom Tom logo after about five seconds, plays part of the drum sound, then that cuts out abruptly and it just sits at the TomTom logo.

    From that screen, holding the power button for around 30 seconds appears to power it off.
  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    Update: Left it sitting on the side at the TomTom logo, not plugged into anything, and once every ten minutes or so it flickers, goes blank and back to the logo again. No sounds, nothing.
  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    Update 2: Tried holding the power button down for a while, it continually tried to reboot, plays three or four drum beats, cuts out, then flickers for a few seconds and does it again.

    Tried opening it up - figured unplugging the battery for a while and then plugging it back in might do something (works with other devices - do TomTom's have a bios or cmos?) but now, despite all of the connections appearing to be seated correctly again, it makes the noise and the screen illuminates that dark-but-lit-up colour, but now no logo.

    While I was watching the video posted above though, I notice that my unit has a thin, silver wire on the left side as you look at the front, apparently running from a socket on the board into the plastic facia. If it wasn't for one end being an obvious socket, I'd write it off as a retainer cable, to stop the face falling off when you take it apart, but it's not on the unit in the video so... I have no idea.
  • nabunabu Posts: 16,890
    Superusers
    Go 50, did the update after a few years not using it


    I still think we need to change the battery
  • AllThisFor1Question_AllThisFor1Question_ Posts: 7 [New Seeker]
    nabu wrote: »
    Go 50, did the update after a few years not using it


    I still think we need to change the battery

    Then I'll get hold a battery and see how that goes then but, I'll be honest - being from the UK and seeing it's ~$10 in the US but £40 here from the same company? Yeah, might just buy a new unit, that's mental.

    Cheers for your help though, much obliged.
Sign In or Register to comment.

Who's Online in this Category0