MyDrive Connect Waiting for your device... — TomTom Community

MyDrive Connect Waiting for your device...

KevinPetersKevinPeters Posts: 2 [New Seeker]
And waiting and waiting...

I am trying to install a map on my Go 400, anything that will fit on the internal memory, in this case the Soiuth West europe map. When I start the process I just get a message on MyDrive saying: "Waiting for Device" and on the device it says "Updating - do not disconnect your device". This goes on for hours with nothing happening. I have tried two different Macs, with a hub, without a hub, different cables, I have updated to the latest version of MyDrive, cleared my cache... Sometimes I am amazed that TomTom still manage to exist with shoddy engineering like this.

Anyway, I would love to put a map on my Go-400. Any suggestions from TomTom?


  • KevinPetersKevinPeters Posts: 2 [New Seeker]
    I've also tried: a factory reset of the device, putting the old SD card back in the slot, using a Windows 10 machine, removing the device from my account a re-adding it.

    It even hangs now on Your Device is Being Added.

    Shoot me now.
  • YamFazManYamFazMan Posts: 20,270
    Welcome to the site....
    If I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here...

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.
    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

  • QuartzQuartz Posts: 0 [New Seeker]
    Am attempting to update my GO 5100 using MyDrive Connect on a MacBook Air with Big Sur 11.3.1. For the last several hours, the MyDrive screen has displayed a message 'Waiting for your device', while the GO 5100 screen is displaying 'Updating', 'Do not disconnect your device'. Is this normal? - and if so how long might the update take? Or alternatively, has the process stalled, in which case what can I do to redeem the situation?
  • JudyYWJudyYW Posts: 0 [New Seeker]
    edited July 14
    Hi everyone,

    My device is GO5000. I was trying to update my device, my laptop can download the updated map however it got stuck at 'waiting for the device' in MyDrive Connect even the device screen is showing it's connected to my laptop.

    I left my laptop (Mac) for hours when I went to bed and in the morning nothing had updated. This is the first time I download MyDrive Connect into my mac as well.

    Does anyone have this problem?
Sign In or Register to comment.

Who's Online in this Category0