Major failure when you have no internet — TomTom Community

Major failure when you have no internet

walkerxwalkerx Posts: 324 [Supreme Navigator]
I have 12 month subscription but today when in an area without a mobile data connection that app fails.
d0wd73vvdcxt.jpg

This app should be able to work when have no connection, otherwise what is point of using it.

Comments

  • Nevergetlost2021Nevergetlost2021 Posts: 3 [New Seeker]
    Same here Tomtom please fix this asap !
  • Nevergetlost2021Nevergetlost2021 Posts: 3 [New Seeker]
    And I am I do know the settings, the Tomtom app has acces to internet for the services and still gives this error. Does it use another app or setting to check the validity of the sub ? We are lost here ........ and is tomtom there just not to get you lost ......
  • szachowaszachowa Posts: 426
    Staff
    Issue is reported under GONAV-3629 (internal ticket) and it is being investigated by developers.
  • CrustyoldmanCrustyoldman Posts: 1 [New Seeker]
    I noticed this problem when staying in an area with no internet coverage, you could plan a route once you hit coverage, very little use if that is 10 miles down the road though
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    Noticed that you can start app on phone without the error message about subscription, but when then connect to android auto the car display will show the message, but if you switch app on car you still get instructions, so this is an android auto bug.
  • MSP60MSP60 Posts: 7 [Master Explorer]
    I got the same message after taking on a subscription. But not always. It baffled me at first. It looks like there is a subscription check the first time of a new day when you start the app through android auto. If your mobile is at that moment off line, you get this message. The problem does not occur when the app is used seperate from android auto. I use the app on a spare mobile in the car with a prepaid SIM and mobile data is normally off. The phone is used for emergencies and navigation (off line maps). So now I switch mobile data on when starting the app with android auto and switch it off again after the app starts.
  • MiClaMiCla Posts: 6 [Apprentice Seeker]
    edited July 18
    Hello,

    When I use TomTom Go navigation with Android Auto, on my car screen, I get a message saying that my subscription must be renewed or, it is valid until June 2022.

    Directly on my smartphone, there is no problem.
  • mapfanaticmapfanatic Posts: 2,121 [Revered Voyager]
    The problem is known, but not yet resolved.
  • MiClaMiCla Posts: 6 [Apprentice Seeker]
    edited July 18
    Thanks, but the amazing thing is that I haven't had a problem for a month.
    This problem happened three or four days ago.

    If Android Auto + TomTom Go are launched from my home, no problem. If I do this outside of my home, there are problems.
  • MSP60MSP60 Posts: 7 [Master Explorer]
    PS probably after every fresh start of the car. Because the app works fine if not connected, it might be an additional subscription check of android auto when android auto connects to the car counterpart sofware.
  • szachowaszachowa Posts: 426
    Staff
    We have fix prepared that should address this problem.

    Please wait for another app update, fix will be available in version 3.1.83 and newer.
  • BinaryBinary Posts: 2 [Apprentice Seeker]
    I've had this app for less than a month and this has happened 4 times, I'm not really impressed. I have to keep stopping the car, park up, check my signal, close the app, start the app, try again... Swear a couple of times, try it all again and finally give up.
  • BinaryBinary Posts: 2 [Apprentice Seeker]
    edited July 20
    I basically can't use the app now, every time I use it I get this error. Are you seriously going to make us wait until you get around to releasing the next version.

    I've noticed that although I have internet connectivity, I can browse through Google... I'm still not able to connect to TomTom's Subscription Servers.
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    szachowa wrote: »
    We have fix prepared that should address this problem.

    Please wait for another app update, fix will be available in version 3.1.83 and newer.

    thanks, what about the app crashing after 1hour and 15minutes of running? Again today this has happened and ended up having to resort to free navigation app to work, as couldn't really stop on a motorway to exit everything and restart the tomtom app.

    it's now become unreliable if have a journey over 75 minutes
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    edited July 26
    still crashes after 1 hour 15 minutes and that's even after uninstalling and reinstalling the app. again had to revert to a free navigation app.

    This discussion was created from comments split from: App crashing after installing Samsung android security patch dated 1 July 2021.
  • iniadaniniadan Posts: 5 [Master Explorer]
    I have version 3.1.75 and have been using Tomtom Go with Android Auto successfully since release.

    I am now on holiday in a rural part of the UK and finding the "renew subscription" bug whenever I try to begin navigation and start a journey in a location with no mobile coverage, of which there are plenty here.

    It does not matter whether I have mobile data set to on or off. If there is no actual mobile data connection the "renew subscription" bug appears on the car display whilst navigation on the phone screen works normally.

    It is pretty frustrating. The workaround is for the passenger to look at the phone screen which works normally. Once we get to an area with mobile data then we can get Tomtom Go working with Android Auto if we kill it, disconnect wired connection from car, reconnect, restart.

    Another workaround is to use Google Maps!

    When is the 3.1.83 fix due to be released?
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    yeh I was in rural scotland and found the issue on latest version as well as previous versions and we shouldn't have to keep reverting to a free app that works offline

    Not sure why the system can't check when online how long is left on the subscription and set a flag on the product to say when it ends. if the standard phone app works then the android auto should work as its the same app.
  • szachowaszachowa Posts: 426
    Staff
    walkerx wrote: »
    szachowa wrote: »
    We have fix prepared that should address this problem.

    Please wait for another app update, fix will be available in version 3.1.83 and newer.

    thanks, what about the app crashing after 1hour and 15minutes of running? Again today this has happened and ended up having to resort to free navigation app to work, as couldn't really stop on a motorway to exit everything and restart the tomtom app.

    it's now become unreliable if have a journey over 75 minutes

    Please share your AppID, we will quickly check it in our crash reporting tool.
    Of course you need to first consent to "help us learn" question.
  • szachowaszachowa Posts: 426
    Staff
    iniadan wrote: »
    I have version 3.1.75 and have been using Tomtom Go with Android Auto successfully since release.

    I am now on holiday in a rural part of the UK and finding the "renew subscription" bug whenever I try to begin navigation and start a journey in a location with no mobile coverage, of which there are plenty here.

    It does not matter whether I have mobile data set to on or off. If there is no actual mobile data connection the "renew subscription" bug appears on the car display whilst navigation on the phone screen works normally.

    It is pretty frustrating. The workaround is for the passenger to look at the phone screen which works normally. Once we get to an area with mobile data then we can get Tomtom Go working with Android Auto if we kill it, disconnect wired connection from car, reconnect, restart.

    Another workaround is to use Google Maps!

    When is the 3.1.83 fix due to be released?

    Please join our open Beta program, fix should be there already. We started process of releasing 3.1.90 to our open Beta testers.
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    @szachowa sent, noticed same appid whether you use the beta or the non-beta version
  • walkerxwalkerx Posts: 324 [Supreme Navigator]
    also not sure who responds to your play store reviews, but the instructions are only useful when you fully stopped and not driving - also the crashes happen if you follow the instructions posted as usually start from the app then plug into car for it to then load on android auto
  • Festus01Festus01 Posts: 1 [New Seeker]
    When will next version be released for non Beta users?
    I've a 6 month subscription for for testing, 2 month are already gone and without offline functionality, testing makes no sense.
Sign In or Register to comment.

Who's Online in this Category1

David_Green_7
David_Green_7