tomtom navi GO 5000 gets stocked in start /reboot process

Chris2021 Registered Users Posts: 2
New Seeker
Hi, when pusing the start/off button on my Go 5000 navi, the "tomtomsymbol" appears but then the device´s start process stops and tomtom symbol is frozen on the screen. (also there is not the typical tomtom drum roll sound - only silence). I also tried the tom tom help for reboot into the recover mode but this does not work, I never come to step 6 (seen the white text). ;)
I hope anyone has an idea how to get the device starting again. Thanks & best regards, Christian


  • nabu
    nabu Posts: 16,890
    Hi I believe that your battery has reached the end
    I had the same thing on a 6000
  • Chris2021
    Chris2021 Registered Users Posts: 2
    New Seeker
    Thanks for the hint "nabu", I charged the battery for hours and tried the same with cable ... so elecriticy should be there. Actually the problem appeared during/after an unsuccesfull try to update a map for the device. TomTom support assumes that is a software mistake and I shoot reboot to recover mode but as there is no particular reboot button on the device, the reboot recovery mode does not work.
  • nabu
    nabu Posts: 16,890
    edited July 2021
    Actually, the problem appeared during / after an unsuccessful attempt to update a map for the device.
    So I think your card is corrupt .a uninstall
  • YamFazMan
    YamFazMan Posts: 21,132
    edited July 2021
    Re... No reset button....
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the device's Operating System afresh

    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound, then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade, large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....


    On the early NAV4 devices like your GO 5000 with 8GB of memory... The Maps fitted easily onto the 8GB of on-board Memory....
    But the Map sizes increases with every update... Now the 8GB limit on-board Memory size on the NAV4 devices is an unfortunate, but real Catch22 situation....
    The latest NAV4 Full Europe Map size is now approaching 9GB
    @VikramK or @lampard one of the Forum Moderators can allocate a small local Map to the Account to get past the 'Catch22' No Maps Found error....

    See Catch22...

    Tomtom FAQ... No maps available (MyDrive Connect)

    Tip... If you are using a Micro SDHC Memory Card, Try removing the Card and restarting the GO 5000....

    Stay Safe... ATB YFM
  • VikramK
    VikramK Administrators Posts: 14,273
    Hi @Chris2021
    The Europe map should be offered to you in smaller regions now.
    You can install is smaller map to the internal memory as a back-up to avoid 'No maps found' situation.