go 620 constantly rebooting — TomTom Community

go 620 constantly rebooting

altimesaltimes Posts: 1 [New Traveler]
Ever since I updated my Go 620 and it showed up as a Go Supreme (Scotty from marketing, please give me a break...drongo). I have been suffering from this (https://discussions.tomtom.com/en/discussion/1126692/anybody-having-problems-with-their-gps-going-blank-or-shutting-down-when-sync-to-my-drive-is-on) problem..... Now, I have owned several devices, but the account has only has ONE device associated with it. Disabling sync appears to stop the problem. I would suspect that the back end severs now think that I have both a Go 620 and a Supreme.......

Is there any sign of this issue being resolved ??? Given it was seemingly known about a year ago you would have thought it could have been addressed by now.....

Answers

  • VikramKVikramK Posts: 12,485 Moderator
    Hi @altimes
    We already have an open ticket to investigate this issue.
    I would recommend reporting this to our customer service team.

    Regards, Vikram
  • YamFazManYamFazMan Posts: 19,921
    Superusers
    edited June 10
    Hi
    @altimes
    Welcome to the site....
    With MyDrive Connect running... Tap the Cogwheel Icon screen top right to access the Setting Menus.... Check the Australia (English)
    Then Save Settings....
    magn15a8xr3d.jpg
    Also check your Tomtom Account is Australian....
    Scroll to the top of the forum page --> Click on the Support Tab
    Log into your Tomtom Account --> Scroll to the bottom of the Support/Forum page... Check your Countries Flag

    Stay Safe... ATB YFM
  • altimesaltimes Posts: 1 [New Traveler]
    Just checked, My Drive Connect was set to Australian. So not a root cause. Support was configured to UK, changed to local, but that only seems to effect the marketing --(

    I will turn sync back on the device, but I be honest, I'll not do not have much optimism 8-(

    If I had not come across the post regarding disabling sync, the thing was headed for electronic recycling and TomTom business for something similar. The device is only a couple of years old which is the only thing that made me believe it was not a hardware issue, just piss poor QA in the firmware.

    Thanks for the comments. And sorry Vikram, I am not going to waste my valuable time trying for support when it is clearly a known issue that should have been corrected before now. Hopefully it will get fixed in some future update....

  • altimesaltimes Posts: 1 [New Traveler]
    Just checked, My Drive Connect was set to Australian. So not a root cause. Support was configured to UK, changed to local, but that only seems to effect the marketing --(

    I will turn sync back on the device, but I be honest, I'll not do not have much optimism 8-(

    If I had not come across the post regarding disabling sync, the thing was headed for electronic recycling and TomTom business for something similar. The device is only a couple of years old which is the only thing that made me believe it was not a hardware issue, just piss poor QA in the firmware.

    Thanks for the comments. And sorry Vikram, I am not going to waste my valuable time trying for support when it is clearly a known issue that should have been corrected before now. Hopefully it will get fixed in some future update....

  • altimesaltimes Posts: 1 [New Traveler]
    Just checked, My Drive Connect was set to Australian. So not a root cause. Support was configured to UK, changed to local, but that only seems to effect the marketing --(

    I will turn sync back on the device, but I be honest, I'll not do not have much optimism 8-(

    If I had not come across the post regarding disabling sync, the thing was headed for electronic recycling and TomTom business for something similar. The device is only a couple of years old which is the only thing that made me believe it was not a hardware issue, just piss poor QA in the firmware.

    Thanks for the comments. And sorry Vikram, I am not going to waste my valuable time trying for support when it is clearly a known issue that should have been corrected before now. Hopefully it will get fixed in some future update....

  • altimesaltimes Posts: 1 [New Traveler]
    Just checked, My Drive Connect was set to Australian. So not a root cause. Support was configured to UK, changed to local, but that only seems to effect the marketing --(

    I will turn sync back on the device, but I be honest, I'll not do not have much optimism 8-(

    If I had not come across the post regarding disabling sync, the thing was headed for electronic recycling and TomTom business for something similar. The device is only a couple of years old which is the only thing that made me believe it was not a hardware issue, just piss poor QA in the firmware.

    Thanks for the comments. And sorry Vikram, I am not going to waste my valuable time trying for support when it is clearly a known issue that should have been corrected before now. Hopefully it will get fixed in some future update....

  • altimesaltimes Posts: 1 [New Traveler]
    Just checked, My Drive Connect was set to Australian. So not a root cause. Support was configured to UK, changed to local, but that only seems to effect the marketing --(

    I will turn sync back on the device, but I be honest, I'll not do not have much optimism 8-(

    If I had not come across the post regarding disabling sync, the thing was headed for electronic recycling and TomTom business for something similar. The device is only a couple of years old which is the only thing that made me believe it was not a hardware issue, just piss poor QA in the firmware.

    Thanks for the comments. And sorry Vikram, I am not going to waste my valuable time trying for support when it is clearly a known issue that should have been corrected before now. Hopefully it will get fixed in some future update....

Sign In or Register to comment.

Who's Online in this Category0