USB not recognised

KevinJ79
KevinJ79 Registered Users Posts: 2
Apprentice Seeker
I am trying to connect my Tomtom to my computer to update the maps on the mydrive connect app. But the computer says the usb isn't recognised. I also cannot find it when going in to 'manage' on explorer.
I have reset the Tomtom, checked for driver updates on my computer (all good), uninstalled the mydrive connect, reinstalled mydrive connect. I'm not at my wits end as to what to do next.
Computer is a PC running on Windows 10 and code for Tomtom starts with XR

Answers

  • VikramK
    VikramK Administrators Posts: 14,062
    Moderator
    Hi @KevinJ79
    Welcome to the community!
    Are you using a TomTom supplied USB cable to connect the device?
    Have you tried connecting to an alternate USB port?

    Perhaps you can also try troubleshooting steps here- https://docs.microsoft.com/en-us/troubleshoot/windows-server/backup-and-storage/usb-device-not-recognized-error

    Regards,
    Vikram
  • KevinJ79
    KevinJ79 Registered Users Posts: 2
    Apprentice Seeker
    Yes I have tried a different USB port as well as a different computer. And it is the USB cable supplied with the device
  • Thomas1278
    Thomas1278 Registered Users Posts: 2
    New Seeker
    edited August 2021
    Hello Kevin.

    I currently have the same problem Windows 10.
    I've tried everything and still doesn't work.




    Mod edit: Machine translated (German)
  • JCGuhr
    JCGuhr Registered Users Posts: 1
    New Seeker
    edited August 2021
    Got the same problem with a GO 6200




    Mod edit: Machine translated (German)