Bluetooth to headset not connecting

Flook
Flook Registered Users Posts: 25
Legendary Explorer
edited June 2021 in RIDER
Hi all, new here. My question is this:-

I have just purchased the rider 500 but I cannot get it to connect with bluetooth to my BMW helmet headset. It shows the BMW headset but not connecting.

I have tried it out many times to connect including direct to the Rider 500, via the phone as the instructions recommend, and all it shows on the display is the headset but no connection. I have carried out the BMW instructions for bluetooth connectivity each and every time.

I have tried this in various ways but just will not connect, it is driving me up the wall :s:#:)

Can anyone please assist.

Many thanks

Flook

Answers

  • rider1rider
    rider1rider Registered Users Posts: 1,447
    Exalted Pioneer
  • Flook
    Flook Registered Users Posts: 25
    Legendary Explorer
    Thanks for the reply rider1, the headset does not seem to be on that list. However it worked okay with my rider V5 and the previous one a V3 =) , so it should work with the rider 500! Or am I barking up the wrong tree here :s .

    Flook B)
  • Flook
    Flook Registered Users Posts: 25
    Legendary Explorer
    Just thought I would bring an update.
    I have just been on the phone to BMW, and they have told me it is quite possible my headset will need to be updated, not replaced (thank goodness). So this afternoon I will be visiting Wollaston's of Northampton to have it checked out. If it is good I will get back to up date here.
    So, here I am now hoping all will be sorted soon.

    Flook B)
  • Flook
    Flook Registered Users Posts: 25
    Legendary Explorer
    Okay, an update. BMW Wollaston @ Northampton have now tried to update my system 6 BMW headset. Unfortunately for me there are no present updates to enable it to pair with the Rider 500.

    This means I now unfortunately have to have headset replaced, which I am disappointed about as I have had it now around 6 years, and because it worked on my previous rider the V5, I assumed it should work on the new one. Silly me.

    However, if Rider1 had added to his post that if it was not on that list he kindly gave then it would be in effect be obsolete.

    Thanks again

    Flook B)