Can't login via Wifi to update, nor can I login to MyDrive on device — TomTom Community

Can't login via Wifi to update, nor can I login to MyDrive on device


I have a Tomtom Go6200. I normally update it via WiFi, or sometimes when connected to the iMac. Recently, when trying to update, it failed to connect. I tried it via WiFi and via cable - neither worked. I have confirmed that I'm using the correct login credentials & password, and have confirmed that the device is connected to a functioning WiFi network. I've done a factory reset (via the System menu) several times - and even after that, it still fails. The message I get is "oops - we are having trouble accessing TomTom Services. Please try again later"

This problem has persisted for one week, and I've tried multiple times over that week. I can connect the device directly to the iMac, select updates etc - but they fail to install.

Any help would be much appreciated.



  • Kam_palaKam_pala Posts: 4 [New Seeker]
    Bro the TomTom Services sucks...I have been getting the same messages for a week now since I bought a GO 620.
  • Matthew1710Matthew1710 Posts: 3 [Novice Seeker]
    Surely I'm not the only one with this issue - are there any TomTom support staff here?
  • DJSheridanDJSheridan Posts: 124 [Sovereign Trailblazer]
    edited June 2
    @Matthew1710 I'm getting to the stage that Tom Tom have got a huge problem and they are trying desperately to cover it up!

    Sorry to say it but my device has lifetime Speed Cameras and Map updates for life... but on my account it claims my Speed Camera subscription has run out and so need to pay for it.
    Now although my device Speed Cameras are still active and working (and upgrading) I have been told Tom Tom are aware of the issue - but have been for some months now!

    Added to this my Speed Camera database appears to have lost all Mobile Locations.

    Anyhow hoping that @lampard or @VikramK will check this out and assist for you.
  • pauljames140pauljames140 Posts: 35 [Apprentice Traveler]
    Start 50 says it wont connect to my drive. (Cannot update my places) Mydrive on the PC says the start 50 is connected. It sometimes says "Oops. We are having trouble... etc.
Sign In or Register to comment.

Who's Online in this Category0