Device is not recognised by the computer or My Drive. — TomTom Community

Device is not recognised by the computer or My Drive.

TwistgripTwistgrip Posts: 1 [New Seeker]
edited June 2 in MyDrive Connect
I have not used the device for a while and have not updated it for a long time either. When I plug it in to the usb port the GO 500 turns on but is not recognised by the computer, there is no sound from the computer as is usual, and My Drive does not turn on.
If I manually open My Drive the device shows as not connected.
I have also done a factory reset "just in case".
The device does not show in device manager; other TomToms that I have perform normally on the same computer.
I think, therefore that it is reasonable to presume that the fault lies within the unit.
Otherwise the unit performs normally and has reset itself correctly.
It is usable, I just can't update it.
So, do you know of a solution for this type of fault? Does the unit need repair, if so how do I proceed?
Your feed back would be appreciated.
in case it helps the serial number is QXxxxxxxxxx460.
Regards





Mod edit: Please don't post private or personal information on a public forum. Thanks!

Answers

  • VikramKVikramK Posts: 12,158 Moderator
    Hi @Twistgrip
    Welcome to the community!
    Since you mention that there is no problem connecting other devices, it could be a connection issue related to the hardware.
    However, I would advise contacting our customer service to report the issue. They will be in a better position to take a call.

    Helpful link-https://help.tomtom.com/hc/en-gb/articles/360015568919/

    Regards, Vikram
Sign In or Register to comment.

Who's Online in this Category0