Lifetime traffic and speed cameras not working on Go Professional 620 — TomTom Community

Lifetime traffic and speed cameras not working on Go Professional 620

Graham1958Graham1958 Posts: 15 [Outstanding Explorer]
Lifetime traffic and speed cameras have stopped working on my Go Professional 620 which I need to be working for my job. I have checked my device and they are showing as active but when I try to connect a message comes up ( Unable to connect to TomTom Services please try again later ) this has been going on for a week. I have tried everything

Answers

  • LochfrassLochfrass Posts: 15,456
    Superusers
    It reads to me as if it doesn't get internet data via bluetooth.
    Have you paired it with a smartphone through which the navigation device can connect to the internet?
    Do you see the MyDrive cloud at the top of the main menu?
  • Graham1958Graham1958 Posts: 15 [Outstanding Explorer]
    Yes I have the Mydrive cloud at the top of the main menu and I am connected through my personal hotspot
  • Da_vid1001Da_vid1001 Posts: 1 [New Seeker]
    I am getting exactly the same problem. I have tried re-setting, switching on and off, and wasted a lot of time checking things out. Can anyone help? Alternatively, how does one get in contact with TomTom directly? They seem to have cut themselves off from their customers!
  • Graham1958Graham1958 Posts: 15 [Outstanding Explorer]
    I’ve had the same problem with TomTom support it is terrible they just give the same response to everyone delete / restore.
  • LochfrassLochfrass Posts: 15,456
    Superusers
    edited May 21
    Da_vid1001 wrote: »
    ..... Alternatively, how does one get in contact with TomTom directly? .....
    Here the user YamFazMan has explained how to contact support:
    https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844

    @Graham1958
    Does the device at home receive traffic data on the home wifi?
    Which phone model do you have Apple with iOS 13 or higher or an Android smartphone?
  • Graham1958Graham1958 Posts: 15 [Outstanding Explorer]
    Traffic or speed cameras do not work on home WiFi, and I am using Apple IPhone 12 iOS 14.5.1
  • LochfrassLochfrass Posts: 15,456
    Superusers
    Maybe the Moderator @VikramK can have a look into your account and finds something unusual
  • VikramKVikramK Posts: 12,186 Moderator
    Hi @Graham1958
    I don't find any issues with the services on the device.
    Have you tried the troubleshooting steps advised on our support article, here- https://help.tomtom.com/hc/en-gb/articles/360014530220

    Regards,
    Vikram
Sign In or Register to comment.

Who's Online in this Category0