How do I stop the GPS position lag? — TomTom Community

How do I stop the GPS position lag?

chas87chas87 Posts: 10 [Apprentice Traveler]
I'm trying the navigation app on my Iphone 11 (1 months sub) and I'm still getting the same position lag as I got when I tried the app last year. Its no good telling me to take the next exit at a roundabout when I'm already 100 meters past the roundabout. If I have to stop at Traffic Lights, the position on the map slowly catches up with my real position. Tomtom is the only navigation app that has this issue so its not the phone.

The app works fine with Honda car play so I wish this could be fixed. Meanwhile I've cancelled the sub and its back to my TomTOM Go satnav.

Comments

  • LevispLevisp Posts: 73 [Supreme Navigator]
    Thats strange I find the exact opposite. The map is very accurate and distance to turn accurate to within 50 feet or so. I'm using iPhone 12 with both Wifi and Data turned on which I believe increases GPS accuracy. I'm using this on a motorbike if that makes any difference to signal. Also I turn off all background apps before using Go. However I have not used the app extensively due to covid restrictions so I need to test more but so far very good.

  • chas87chas87 Posts: 10 [Apprentice Traveler]
    I also have data turned on and wifi is always on. No other background apps. I even got a mount for the phone so its on the windscreen but it made no difference. I repeat, other navigation apps do not have the lag issue, its only TomTom.
  • YamFazManYamFazMan Posts: 19,475
    Superusers
    edited May 14
    Hi
    @chas87
    Does your Car have a Metallized Heat reflecting windscreen/Windows, this can reduce the strength of the signal....
    Some Cheapo Dash Cams have poor RF Shielding, the stray RF can also reduce the satellite signal
    Is the device set low down On or Behind the dashboard

    ATB YFM
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    hi YamFazMan,
    No to all your questions. You obviously didn't read my last post.
  • LevispLevisp Posts: 73 [Supreme Navigator]
    I have just been for a one hour round trip ride on my motorbike. Got MyDrive to create a twisty route. The route was mostly single track gravel everywhere type of roads in the middle of nowhere. A good test. Only just moved so the roads are all new to me. Anyway to the point. Accuracy was spot on. Worked just as well as my Rider 550. In fact better because the screen on my phone is bigger. So the app does work but not for you. There must be some plausible explanation for this. I wonder why it works when running through CarPlay. It's the same app surely. Have you tried using the app in another vehicle ? When a phone is connected to CarPlay does it use a different aerial for GPS reception ? Sorry I cannot help it must be very frustrating.
  • SinglePointSafetySinglePointSafety Posts: 54 [Sovereign Trailblazer]
    AFAIK, phones connected to the infotainment system eg Android Auto, CarPlay, can make use of the car's GSM aerial, but that's mainly for phone calls, not sure if it does much for GPS. FWIW, wife's iPhone running v2.6 does not show any significant lag when TT GO is running purely on the phone.

    YamFazMan, sorry, but you're wrong. Dashcams themselves very rarely cause RF reception issues, it's normally the 12V to 5V adapters, and that's mainly in the frequency which affects DAB reception.
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    @Levisp hi,
    When I said the app works via CarPlay I didn't mean the lag wasn't still there. I subscribed so I could have the display on the Car's screen. I like TomTom. The cars inbuilt Navigation is nothing like as good for traffic and no Speed Camera warnings; Thats why I still use my TomTom Go SatNav. I'm after the best of both worlds - TomTOM on my cars screen - It so close to being great. I'm glad yours works fine.

    It must be some incompatibility with my phone or car,
  • YamFazManYamFazMan Posts: 19,475
    Superusers
    edited May 15
    Hi
    @SinglePointSafety
    (Snip) YamFazMan, sorry, but you're wrong. Dashcams themselves very rarely cause RF reception issues, it's normally the 12V to 5V adapters, and that's mainly in the frequency which affects DAB reception.
    I am not wrong, I did not say all 'Dash Cams'....
    I said Some Cheapo Dash Cams have poor RF Shielding, the stray RF can reduce the satellite signal....

    ATB YFM
  • SinglePointSafetySinglePointSafety Posts: 54 [Sovereign Trailblazer]
    chas87, if other apps don't show any lag, it kind of rules out any phone/GPS reception issues, and anyway, given your phone position in the car as you describe, it should get a good GPS signal anyway.

    TT support would probably tell you to uninstall/reinstall the app as a 'this cures most things' solution. I guess you've tried this as a last resort? Of course, it absolutely should not be the solution, but these apps are sometimes 'weird' and it pains me to admit that this course of action has fixed something on a few occasions for me.

    Good luck in resolving your problem
  • RobKawaRobKawa Posts: 7 [Apprentice Traveler]
    edited May 14
    @chas87,

    I recognise the issue because I had the same with my iPhone. All other apps worked fine accept TomTom. What I did was delete the app and a re-install. The re-installation did not solve the issue.

    But the 2nd time I deleted the TomTom app, did a soft reset and after this I switched off my phone. Then turned it on and installed the TomTom app again.

    Since I did the last re-installation I had no GPS issues anymore.
    Hopefully this will help you to solve the issue on your phone. For me it worked.
  • SinglePointSafetySinglePointSafety Posts: 54 [Sovereign Trailblazer]
    Interesting Rob, thanks and duly noted if we ever experience this issue. The software engineers would no doubt say that your solution absolutely should not have worked - but it did.....!
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    @RobKawa
    Thanks for the info. I have reinstalled the app numerous times but I hadn't tried the soft reset in between reinstalling. I'll give that a try.
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    @RobKawa
    I tried your re-install technique and it didnt work for me the lag is still there. :(
  • RobKawaRobKawa Posts: 7 [Apprentice Traveler]
    edited May 16
    @chas87, that’s a pitty that the issue is not solved.

    Can you please check the following on your iPhone?
    "GPS accuracy depends on the number of visible GPS satellites. Locating all visible satellites can take several minutes, with accuracy gradually increasing over time. To improve GPS accuracy:
    Make sure that you've set the date, time, and time zone correctly on your iPhone in Settings > General > Date & Time. If possible, use Set Automatically.

    It could be that it is set automatically but just in case. 😅

    In the mean time I did some search on the internet and see the you are nog the only one with this issue in combination with an iPhone 11. There could be something not 100% ok with your gos in your iPhone. If you go to an Apple store of Apple premium reseller, they can test it.
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    Thanks for the reply. The time on my phone is Set Automatically. As to going to an apple store for repairs, last time my iphone 6 needed a new battery there was a 6 months waiting list. My sub on the app is about to expire so I just stick to my TomTom GO sat nav. It works perfectly.
  • chas87chas87 Posts: 10 [Apprentice Traveler]
    edited May 18
    @RobKawa
    I need to repeat Apple Map has absolutely NO lag (tested again this morning) so there is Nothing wrong with my phones GPS. The phone was even in the on the center console and not on the windscreen - still no lag.

    My cars own navigation system has the facility to show turn direction on the center display (under where the speed display is on my Honda Crosstar). The apple app does this as well when you are within 100 yds or so of the turn or roundabout. The TomTom app doesn't do this at all.

    I posted a review on the app store marking the app down because of my lag issue and TomTom responded by saying they were aware of the problem and are working to fix it.
Sign In or Register to comment.

Who's Online in this Category0