'Service temporarily unavailable' message trying to update TT Via 135. Has been like this all week! — TomTom Community

'Service temporarily unavailable' message trying to update TT Via 135. Has been like this all week!

is it ever available??


  • Justski2itJustski2it Posts: 1 [New Seeker]
    In trying to update my VIA1530TM (which hasn't been updated in about 2 years), I keep getting error messages "Our servers are busy, try again later" or "Your device is not responding, please try again later" I also get a message that my unit is no longer being supported and a replacement offer is available, but when I try to accept the replacement offer, it says my discount code is no longer valid, and it wants to charge me full price instead of the the 30% off offer....so frustrating. Any help available?
  • VikramKVikramK Posts: 12,202 Moderator
    Hi @Justski2it
    Welcome to the community! Could you try the steps @YamFazMan suggested here

    Thanks, Vikram
  • Justski2itJustski2it Posts: 1 [New Seeker]
    edited May 5
    So, after following the recommendation by @YamFazMan, rebooting my laptop allowed the TomTom program to download the updates; however, now my TomTom unit is showing "Something has gone wrong....This service is temporarily unavailable. Please try again later." I have tried several times, but I get the same message on the unit itself. So very frustrating. Mine is a VIA1530TM, but shows up in my account as a VIA125--but with the correct serial number. What else, if anything, can I try?
  • YamFazManYamFazMan Posts: 19,666
    edited May 6
    If you are still having problems with MyDrive Connect... I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program will usually bring MyDrive Connect back to life...
    See... https://discussions.tomtom.com/en/discussion/comment/1704775/#Comment_1704775
    NEVER have a Tomtom device connected to your PC when....
    (1)... Installing MyDrive Connect (Including Uninstalling & Reinstalling MyDrive Connect)
    (2)... Updating the MyDrive Connect program
    (3)... Modifying MyDrive Connect (i.e... Deleting the Home3 and the MyDrive Connect folders as in the workaround shown above)

    Having your device connected can have an adverse effect on the USB Driver install….

    Stay Safe... ATB YFM
  • CasNCasN Posts: 5 [Master Explorer]
    Installing MyDrive connect ( onto Windows 10) was simple, trouble started when trying to add the device. I keep getting back to the following screen:L
    I am logged on to the device and also logged in to mydrive connect.
    I have tried the same on a different machine, similar results.
    My WiFi is also active and Bluetooth is not active.
    So I tried the various options mentioned here like changing the driver to USB RNDIS6 or USB RNDIS. Fully uninstalled the application and starting from scratch, resetting the TomTom itself but..... results are the same. So what is next?? An answer is highly appreciared :)
  • Alex123456Alex123456 Posts: 6 [Apprentice Traveler]
    edited May 7
    Stuck at the same situation, just keep asking me to login on device.
    I hope this is technical issue, don't want to buy garmin because of this.
  • CasNCasN Posts: 5 [Master Explorer]
    My current device is a Garmin Zumo 660, now moving to TomTom. Hope someone has a proper answer to fix this issue. :#
  • YanneYanne Posts: 2 [Apprentice Traveler]
    I also have this problem when trying to update my maps. The update is downloaded but i will not install it on my Start 25. "Something has gone wrong....This service is temporarily unavailable. Please try again later." I have tried it again....
    I have also tried the suggestions from YamFazMan without any success. I'm thinking the problem is with the start 25 and it's cooperation with Mydrive connect.
    Any suggestions how to solve this?
  • millenium72millenium72 Posts: 2 [New Seeker]
    edited May 10
    Get stuck in the same spot. Can't add the sat nav as a device ... :-(

    Machine translated(German)
  • joegunjoegun Posts: 1 [New Seeker]
    I'm having the same issue, hope it gets fixed, or I'll be returning the device. :(
  • Ste7iosSte7ios Posts: 758
    What are you expecting from MyDrive Connect & 550? With that model you can only use it for cases where there’s no WiFi available and your only option to connect the device to the Internet is through the computer and the USB cable.


    To manage the device, maps, install updates & synch with MyDrive you’ve to connect the device to your WiFi and do everything from the device.
  • YamFazManYamFazMan Posts: 19,666
    edited May 9
    The NAV5 (Wi-Fi) devices normally update using Wi-Fi....
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    Try Option (2)... Connect over USB in the post linked below ....
    See... https://discussions.tomtom.com/en/discussion/comment/1739744/#Comment_1739744

    Stay safe... ATB YFM
  • WatersparkWaterspark Posts: 4 [Apprentice Traveler]
    Same problem with VIA 135 and suggestions from YamFazMan don't fix. Is this a bug in MDC
  • wxman123wxman123 Posts: 2 [New Seeker]
    Having the same issue. Device connects right up, updates download on pc but the gets stuck on waiting on device (on pc screen) while device screen says something has gone wrong, server unavailable. Tried deleting the folders as suggested, but issue persists. Help!
  • wxman123wxman123 Posts: 2 [New Seeker]
    Guys, make sure you get your device to lock onto a valid GPS signal before updating (I hadn't used my device for quite sometime before attempting to update). It does NOT need to have the GPS locked in while actually updating. This is what (finally) worked for me. Hope this helps.
  • VikramKVikramK Posts: 12,202 Moderator
    edited May 10
    Hi @CasN @Alex123456 @millenium72 @joegun @robbers @Justski2it @Yanne

    Could you try a workaround suggested by one of our users on the German community:

    "After reading through three different forums "Threads" with the same problem and with my "An error has occurred ..." problem, which some others also have, I was able to solve the riddle after many hours of searching around . The navigation system does not save the time and sets it back to 2009, especially during the reset processes. That is where the problem lies. It seems as if the update server does not want to accept this old date. I managed to get the navigation system onto the balcony so that it could read the current time and time zone, and my patience was rewarded. Once the time was read in and then strapped back to the USB port, the update process FINALLY starts!"
    - @satmonk

    Comment link- https://discussions.tomtom.com/de/discussion/comment/1756538/#Comment_1756538

    Machine translated(German)

    Regards, Vikram
  • YamFazManYamFazMan Posts: 19,666
    edited May 16
    Thanks for the tip....
    Today the Via 120 Live... Would not update... Just sat there with the error message' Something has gone wrong' etc....

    Just tried the German Workaround... 'All good'
    The update started as soon as I connected the device after getting a GPS Satellite Fix =)

    Has the device received a Satellite Lock ???

    NAV3 Devices... My Via 120 Live....

    From the main menu
    Tap (Settings)
    Right Cursor once for next page
    Tap (Connections)
    Tap (GPS Status)
    View the satellite connected (GPS fix) status
    Follow onscreen prompts to exit

    NAV4 & The Latest (Wi-Fi) Connected devices....
    If the small Satellite Dish is being displayed on the Traffic Bar....
    There is NO Satellite Lock....
    Getting a GPS Satellite Fix....
    Here... https://discussions.tomtom.com/en/discussion/comment/1729800/#Comment_1729800

    If you are still struggling to get a GPS Satellite Fix....
    Try.... https://discussions.tomtom.com/en/discussion/comment/1729801/#Comment_1729801

    Stay Safe... ATB YFM
  • YanneYanne Posts: 2 [Apprentice Traveler]
    wxman123. Thanks a lot. It worked perfectly (I think. It's not finished updating yet but it did start)
  • CasNCasN Posts: 5 [Master Explorer]
    @vikramk , tried the workaround but no luck. My time was also already set correctly. Anyway, I will use WiFi, that works as a charm. (do think TT should fix this properly).
  • SussexDabSussexDab Posts: 15 [Master Explorer]
    I have the same problem.
    I have tried all of the things listed above plus all of the things listed here:
    I have set the time manually ( including the year) and then got a satellite lock but does not solve the problem.
Sign In or Register to comment.

Who's Online in this Category0