Update my NB1 card with TomTom HOME

BramMazda Registered Users Posts: 1
Apprentice Seeker
edited December 2020 in Built in car navigation
I have a problem when I wanted to update my NB1 with the new TomTom HOME (v2.20.15.105). My memory card was first not detected by TTH, but after I read about a known issue (with the loopdir folder) I followed the steps. The end result didn't solve the problem. I still cannot connect the memory with TTH. TTH keeps telling me there is an error on the card....

Navigation - Purchased in : Mazda NB1 Live - 2014
Computer - OS : MacBook Pro 2016 - Mac OS v10.15.6
Memory Card : detected as TOMTOMDISK


  • lampard
    lampard Retired TomTom Employee Posts: 6,075 Retired Community Moderators and Admins
    Hi @BramMazda

    Welcome to the COmmunity! I would advise you to restore the SD card by following the steps here in the link (Start from step 3). It's the only option left other than trying on a different machine to update.

    Regards, lampard
  • hpk
    hpk Registered Users Posts: 2
    Apprentice Traveler
    I also have this problem! I closely followed the instructions that were given in the link supplied by the moderator, I even tried it with a brand new SDHC memory card (8 GB) with the same size as the original MAZDA card, but always the same error massage appears "There are errors on your memory card that cannot be repaired by HOME. To fix these errors, ins..." The original card functions without a problem in the car, but I cannot keep the maps updated because of the error in the HOME app. Both cards also function properly on the computer. Very annoying. What is the problem here?
  • kdrakon
    kdrakon Registered Users Posts: 1
    New Traveler
    If anyone else comes across this issue like I did: I went through the above guidance, but it didn't help. I did come across the following issue:

    After restoring my SD card with the backup made from the steps at https://help.tomtom.com/hc/en-gb/articles/360013961519 as suggested by lampard, and going back to my car and verifying the maps could load, I went back to my laptop and:
    • deleted the 'loopdir' directory on the SD
    • went back to the car and started with the SD card loaded (waited for the Nav to show up)
    • went back to my laptop, inserted the SD, and started TomTom Home
    Right away, the 'device' was recognized. It would seem then that formatting and restoring the card was not necessary, but deleting the 'loopdir' was all that was needed.
  • jmschadler
    jmschadler Registered Users Posts: 1
    New Traveler
    I also have the same problem. I've followed all the steps and advice I could find, including formatting and restoring the card, deleting the loopdir and rebuilding it from the Nav system. All to no avail. However, when I installed TTH on a friend's laptop running Windows it works just fine with no issues.

    Unfortunately, I don't have easy access to a Windows machine.

    I'm using a 2012 MacBook Pro running MacOS 10.15.7 (Catalina)
  • PeteSm
    PeteSm Registered Users Posts: 5
    Apprentice Traveler
    edited February 2021
    Hiya- repeat problem but no access to a Windows PC to resolve. I haven't got a backup but have purchased maps. The advise conflicts between using Connect and Home- what is the answer please TomTom?

    If you cannot help, please refund my Live and Map update!
  • RichardGate
    RichardGate Registered Users Posts: 1
    New Seeker
    Hi, I was having this problem with all the issues noted above, recovery suggestion did not work.
    After much messing about it seem the Mac version of Tom Tom Home has a "problem" with older un-updated SD cards. Mine was from 2013 and had not been updated since. I used the Windows version which recognised the card ok and updated it. Then I use the Mac version and it now recognises the card and can apply additional updates. The card, with updates, works fine in the car too.
  • aectann001
    aectann001 Registered Users Posts: 1
    Apprentice Seeker
    Experiencing the same issue.

    I updated my Mazda NB1 SD card last year: bought a subscription and installed new maps. Now trying to run TomTom HOME to update the maps with no success: "there are errors on your memory card that cannot be repaired by home".
    I deleted the loopdir, inserted the card in the car, turned on navigation, waited until it loads, removed the card, used TomTom... and the same error once again.

    I use Macbook Pro, Mac OS X 11.2.1. No idea how I can get a Windows laptop as some people suggest.


    Please advise how to fix the issue.
  • Morild
    Morild Registered Users Posts: 2
    Apprentice Traveler
    I would install Parallels on your MacBook. Then Run the Windows install from there. Or simply ask a friend or college if you could lend his/hers PC and run update your SD card from there once. Once updated it works from Mac again
  • tomtom_tomtom
    tomtom_tomtom Registered Users Posts: 1
    New Seeker

    I've also run into this exact problem (Mazda 6, NB1, TomTom Home on OSX Catalina).

    I have a support ticket open. Ticket ref is 1258774, helpdesk email is [email protected]

    Support have been responsive and have requested my log files etc, but say they need more data to debug the issue. So, if you're having the same problem, please do drop them a line.