Failed update, what next ?

Alex-DRZ Registered Users Posts: 3
Apprentice Seeker
edited October 2020 in RIDER
After filed update of a map i can't access Map section anymore on the device (each time it will trigger never ending loop update).
Things i tried:
  1. Waiting to finish update (it will start from 42% then go to 99% and back again from 42%)
  2. Soft reset (no results, it will display 2 updates and loop again)
  3. Recovery (no results, loop again)
  4. Download maps via MyConnect or WiFi (same thing, it will loop 2 downloads as before)

I can't delete current map or install some another one, every time i tap on Map (on device) it will start update process.

What to do next ?

*device TomTom Rider 550


  • TigerRider
    TigerRider Registered Users Posts: 176
    Exalted Navigator

    Seems you have already tried the usual solutions. It might be worth ensuring the thing is fully charged before attempting any major updates. If your charging solution times out for any reason things could get a bit flaky towards the end of the update cycle and fail.

    It occurs you might disable the WiFi to prevent it updating on its own then power cycle it before moving on. This might give you a window to get in and delete the maps before it takes over again. If that doesn't work try a harder reset:

    From the manual: "To do this, press and hold the On/Off button until your TomTom Rider begins to restart."

    Is your Internet connection stable enough? It's not folk around you soaking up all the bandwidth watching Netflix is it?
  • Alex-DRZ
    Alex-DRZ Registered Users Posts: 3
    Apprentice Seeker
    Reviving this thread since travel wasn't possible.
    Currently mi device is unusable, update starts from 42% and then loops back from 99 to 42%, endlessly.
    My internet connection is 100/100mbps so that can't be an issue.

    Simple and straight question, how can I use my device for navigation and new maps updates?
    Does this mean my device is done after simple failed update?
  • DougLap
    DougLap Posts: 9,960
    Hi @Alex-DRZ

    @VikramK or @lampard should pick this up tomorrow and review your units logs on the TT servers and then they can advise what to do. Look back here to see what they say.

  • VikramK
    VikramK Administrators Posts: 14,070
    Hi @Alex-DRZ
    Welcome to the community!
    The problem is related to pending downloads and also the firmware is not updated on your RIDER.

    This is mostly caused due to security software/firewalls or restricted networks blocking connections.

    More explanation available under Case 3.1 in the article here

    Thanks, Vikram
  • Alex-DRZ
    Alex-DRZ Registered Users Posts: 3
    Apprentice Seeker
    @VikramK , sorry but that does not make any sense. I'm network engineer working from home, so anything related to network/isp we can cross from list as non-issue.
    I tried to sign with new tomtom account, same thing, 3 updates (1.7gb) starts as soon as I open "Maps" on device. I even tried to leave device in update loop till battery gave up, still the same it will pick up update from 48% and loop again.
    What else can I try ?