Go 5200 Speed Camera issue — TomTom Community

Go 5200 Speed Camera issue

I have purchased the 5200 which supposedly has lifetime maps, traffic updates and speed camera updates.

I turn it on and use it probably once every 1 - 2 months.

Logged into the website today and it is showing this:
zx6ektgod7fz.png

x6lutnr3k7ao.png


I even went to click on purchase and it has billed me £0.66.

However, I am confused because why would I need to pay for them, when I already have lifetime?

Is this an error on the website?

How do I get my refund of £0.66 back?

How do I verify I am getting speed camera updates?

Many thanks




Mod edit:
Image edited to remove device serial number.
Please don't post private or personal information on a public forum. Thanks!

Answers

  • DougLapDougLap Posts: 8,239
    Superuser
    Hi @Centricmalteser

    Firstly @VikramK or @lampard should pick this up on Monday and if necessary sort out your units settings on the TT servers. Look back then to see what they say.

    Regarding the payment you have made for the cameras you will need to contact Customer Support via Chat to sort that out. In the meantime go to the Tomtom main website and log into your account top right. You will then see a person figure appear top right which if you click on will give you some new headings just below the top of the page. One heading is Subscriptions and if you click on that you should see your purchase and there is an option to cancel the subscription. This will not generate a refund but should stop any other payments.

    Doug
  • DJSheridanDJSheridan Posts: 112 [Sovereign Trailblazer]
    edited April 17
    Hi @Centricmalteser
    It is a server issue on the website.
    I had the Go 5200 and now have a Premium X - both say the same thing for me too.
    If you look on the settings of your device and also logging in to My Drive Connect you will see it does have them loaded.

    Only issue I still have is that the Speed Camera Database seems to be having other issues as only Gatso and Average Cams are appearing - no Mobile Sites seem to be on mine.

    Hopefully it will get sorted soon.
  • VikramKVikramK Posts: 12,186 Moderator
    edited April 21
    Hi @Centricmalteser
    Welcome to the community! The device comes with speed cameras updates for the lifetime of the device.

    If you go into- Main menu- Settings- System- About- Under subscriptions

    What do you see as the status of speed camera services?

    The deactivated message on the account page you see above is a website bug and it's already been reported to the team.

    I also see you paid for a monthly subscription, please contact our customer service to raise a refund request for the same.

    Regards, Vikram
  • NLDavidNLDavid Posts: 7 [Master Explorer]
    I seem to have a similar problem: late last year I bought a Premium 6", I think it comes with lifetime everything?

    Few weeks ago I updated it, and some time later TomTom sent me a bill by e-mail of 29,99 euros.
    I didn't purchase anything, just updated the navigation.
    Very odd that they charged me by automatic debit for something that is standard and not optional?

    (Could not figure it out through "MyDrive" so I blocked the payment)
  • DougLapDougLap Posts: 8,239
    Superuser
    Hi @NLDavid

    If you go to TomTom's main webpage and log into your account Top Right then Tapped the Person Icon that then appears top right you will get a few extra headings at the top related to your account. Any order etc should appear there so can you see what the charge was for.

    You should not get any charges for Traffic/Cameras/Maps etc.

    Doug
Sign In or Register to comment.

Who's Online in this Category0