No traffic information on GO Discover — TomTom Community

No traffic information on GO Discover

AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
edited April 12 in GO Discover & GO Expert
I cannot get any traffic information on my Go Discover. The traffic subscription is 'activated'. The smartphone is connected via bluetooth, bluetooth tethering is selected and my phone is correctly identified as a 'paired phone'. In 2 weeks I have seen no traffic information whatsoever. I would be grateful for any guidance

Answers

  • YamFazManYamFazMan Posts: 20,282
    Superusers
    edited April 7
    Hi
    @Amakhosi
    Welcome to the site....
    The GO Discover must be connected to Bluetooth + A Personal Hotspot (Bluetooth).... You should not be asked for a Password (Password is for a Wi-Fi Hotspot)
    Here... https://download.tomtom.com/open/manuals/TomTom_GO_DISCOVER/html/en-gb/index.htm#HowToConnectWithBluetooth.htm

    Stay Safe... ATB YFM
  • patrickvqpatrickvq Posts: 2 [New Seeker]
    Same problem today : phone is Samsung Galaxy S10, bluetooth and bluetooth tehering are on, TT Go discover says smartphone is properly connected, traffic info is activated as well as "flitserupdates", still tomtom services does not respond...
  • VikramKVikramK Posts: 12,866 Moderator
    edited April 14
    Hi @Amakhosi @patrickvq
    We have fixed a few things in the backend.
    Could you do a factory reset and check the device connects?

    Main menu-settings-system-reset device

    Or we would like to know if the Traffic is working when the device is just connected to a WiFi® internet connection.

    Regards, Vikram
  • AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
    Hi Vikram:

    As you suggested, I completed a factory reset and then carefully followed the connection process. My phone, A Samsung Galaxy A20, was shown on the TomTom as connected (in blue) but no traffic information was available when I selected a route. Bluetooth, Phone Visibility and Bluetooth Tethering were all selected on the phone.

    There was no change when just connected to a Wi-Fi internet connection.

    This is getting tedious!

    Regards

    Amakhosi
  • VikramKVikramK Posts: 12,866 Moderator
    Hi @Amakhosi
    Thanks for checking, I will forward this to my team and get back soon.

    @patrickvq
    Have you tried the steps in my comment above?

    Thanks, Vikram
  • AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
    Hi Vikram:

    Good news. This morning I tried once more to connect my smartphone and , for the first time, appear to have traffic info. My process was the same, the outcome was different. Let's hope that this is now repeatable.

    Regards

    Amakhosi
  • DougLapDougLap Posts: 9,122
    Superuser
    edited April 15
    Hi @amakhosi

    The same think happened to me this week. Out of curiosity did you download the map updates to your unit just before the Traffic returned which is what happened to me. This could be of interest to @VikramK if it was the case.

    Doug
  • AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
    Hi Doug;

    Unit is new so have not felt the need to update maps yet. Traffic info is the priority.
  • DougLapDougLap Posts: 9,122
    Superuser
    Hi @Amakhosi

    Okay. I was referring to the small weekly updates. The update I was referring to was only 8.8mb this week for the 18 countries in the Europe map that I have installed on my device.

    Doug
  • VikramKVikramK Posts: 12,866 Moderator
    Hello all,

    My team just informed me that is better to avoid a factory reset as the first solution when the device is unable to connect to TomTom Services.

    Just turn off the device -
    Press and hold the ON/OFF button for 2-3 sections and tap on 'Turn off'

    Turn on the device and make sure your phone is paired for data connection using Bluetooth.

    Thank you, Vikram
  • AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
    Hi Vikram;

    Four days after you advised me to complete a factory reset you now tell me not to! The traffic information feed to my Go Discover is unreliable, at best, and it is clear from the internet that others are also having problems with this function.

    Neither the product nor the technical support meet the standards that I have previously experienced from TomTom. This is not a positive message from your organisation about its regards for the customer.

    Regards

    Amakhosi
  • VikramKVikramK Posts: 12,866 Moderator
    edited April 20
    Hi @Amakhosi
    A factory reset is one of the standard ways to troubleshoot the connectivity issue.

    However, my team later got back to me advising that we should first try to fix the problem by doing a restart[Turn OFF ->Turn ON]

    My previous comment was just advice for users who might land on this topic with a similar issue in future.

    Are you still having issues with your GO Discover not connecting to TomTom Services?


    Thanks, Vikram
  • AmakhosiAmakhosi Posts: 6 [Apprentice Seeker]
    Hi Vikram;

    Following the factory reset that you suggested, I have now completed 2 consecutive journeys when traffic info has been available. Finally, it looks as though the SatNav is working correctly.

    Thanks

    Amakhosi
Sign In or Register to comment.

Who's Online in this Category0