Linking Rider 410 to my account in MyDrive Connect — TomTom Community

Linking Rider 410 to my account in MyDrive Connect

James_646James_646 Posts: 10 [Apprentice Traveler]
edited April 12 in RIDER
How long should it take to add my device, it has been connected for 30 mins and just say's Your device is being added. do not disconnect your device
Thank's in advance

Best Answers

  • YamFazManYamFazMan Posts: 20,311
    Superusers
    Accepted Answer
    Hi
    @James_646
    Welcome to the site....
    I assume the device is a Rider 410
    To register a previously used device to your Account....
    You must initiate a Factory Reset before you can change from the previous owners account and register the Rider 410 to your Account....
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> Reset device....
    This will reset the device to back to the default factory setting....

    Maybe useful... Tomtom Rider 4xx User guide....
    Here... https://help.tomtom.com/hc/en-gb/articles/360014295300-Rider-450-420-42-410-400-40-User-Manual

    Stay Safe... ATB YFM
  • YamFazManYamFazMan Posts: 20,311
    Superusers
    Accepted Answer
    Hi
    @James_646
    The Rider Mount need a 12v supply....
    If you power the device through the USB socket instead of the Mount... The 1st ride in the rain will probably fill the device with water and kill it...

    ATB YFM
  • James_646James_646 Posts: 10 [Apprentice Traveler]
    Accepted Answer
    Thank's again

Answers

  • YamFazManYamFazMan Posts: 20,311
    Superusers
    Accepted Answer
    Hi
    @James_646
    Welcome to the site....
    I assume the device is a Rider 410
    To register a previously used device to your Account....
    You must initiate a Factory Reset before you can change from the previous owners account and register the Rider 410 to your Account....
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> Reset device....
    This will reset the device to back to the default factory setting....

    Maybe useful... Tomtom Rider 4xx User guide....
    Here... https://help.tomtom.com/hc/en-gb/articles/360014295300-Rider-450-420-42-410-400-40-User-Manual

    Stay Safe... ATB YFM
  • James_646James_646 Posts: 10 [Apprentice Traveler]
    Thank's for you reply and info, the previous owner had reset the device. I got a bit fedup so I dissconnected it from The PC and plugged it back in ans hey presto there it was. So I think all is well. Once again thank you for you advice.
    James :)
  • James_646James_646 Posts: 10 [Apprentice Traveler]
    Just one more question for you, can you power the 410 via the USB on the bike, I am actually riding a trike
  • YamFazManYamFazMan Posts: 20,311
    Superusers
    Accepted Answer
    Hi
    @James_646
    The Rider Mount need a 12v supply....
    If you power the device through the USB socket instead of the Mount... The 1st ride in the rain will probably fill the device with water and kill it...

    ATB YFM
  • James_646James_646 Posts: 10 [Apprentice Traveler]
    Accepted Answer
    Thank's again
Sign In or Register to comment.

Who's Online in this Category0