TomTom Go 50 disables notebook wifi — TomTom Community

TomTom Go 50 disables notebook wifi

Hi all, I've a problem on my notebook with Windows 10Pro 20H2 when I connect my TomTom Go 50.
It happens that as the notebook detects the device, the wifi network is disabled and this denies any connection to internet. In the network panel a new ethernet net appears and the wifi is disabled: why?
I've checked the driver on Device Manager - Network adapters and it seems a NDIS generic driver is used since the name TomTom doesn't appear.
How can I fix it?
Thanks in advance for any help
Tagged:

Answers

  • LochfrassLochfrass Posts: 14,659
    Superusers
    I have only read this 2-3 times so far but always without a proper solution.
    NDIS compatible device is your navigation device.
    What happens if you disable this in the network settings?
  • YamFazManYamFazMan Posts: 19,239
    Superusers
    edited April 3
    Hi
    @mferu
    Welcome to the site....
    Maybe useful....
    See Post by User Niall... https://discussions.tomtom.com/en/discussion/990415/how-to-stop-your-device-from-killing-your-windows-wifi-network-connection
    Stay Safe... ATB YFM
  • mferumferu Posts: 5 [Apprentice Traveler]
    @Lochfrass thanks for your reply.

    If I disable the NDIS in the network settings, everything works properly. The same if I connect through normal cable.
    The issue happens only if the notebook uses the wifi connection.
  • mferumferu Posts: 5 [Apprentice Traveler]
    @YamFazMan, nice to meet you all.

    Thank you for your suggestion, I looked for it but I wasn't able to find.
    I will try to apply what suggested in those posts and I'll be back to you with the result.
  • mferumferu Posts: 5 [Apprentice Traveler]
    YamFazMan wrote: »
    Hi
    @mferu
    Welcome to the site....
    Maybe useful....
    See Post by User Niall... https://discussions.tomtom.com/en/discussion/990415/how-to-stop-your-device-from-killing-your-windows-wifi-network-connection
    Stay Safe... ATB YFM

    I tried all what suggested but none of them worked. The only solution for avoiding my problem is to connect via Ethernet cable and not via wi-fi .... that’s very disturbing.

    Any other help? Please?
  • YamFazManYamFazMan Posts: 19,239
    Superusers
    edited April 7
    Hi
    @mferu
    Post Edited....
    The active Data connection on Tomtom Devices can have a higher connection priority over other connections... For example, you are at Home with your Tomtom Wi-Fi device connected to a USB port on your PC, and using it as a power supply + MyDrive connect running on your PC ???
    The USB connection ON THE DEVICE >> WILL << take priority over the Wi-Fi Connection ON THE DEVICE....

    Disconnect the USB Lead from your PC....
    If you want to charge the device while updating it, use something like a Smartphone Charger and the Tomtom USB lead.....

    Note... If you are using MyDrive Connect with the default setting then MDConnect Auto Starts with the PC....
    I have disabled this feature using the MDConnect Setting Menus & created a Desktop shortcut to start MDConnect when required....
    ____________________________

    Maybe useful... Further info on Tomtom GPRS Live Devices & Data Connection priority over the SIM Card....
    Here... https://discussions.tomtom.com/en/discussion/comment/1750669/#Comment_1750669

    ATB YFM
  • mferumferu Posts: 5 [Apprentice Traveler]
    YamFazMan wrote: »
    Hi
    @mferu
    Are you at Home/Somewhere with your Tomtom Wi-Fi device connected to a USB port on your PC, and using it as a power supply + MyDrive connect running on your PC ???
    The USB connection ON THE DEVICE >> WILL << take priority over the Wi-Fi Connection ON THE DEVICE....

    Disconnect the USB Lead from your PC....
    If you want to charge the device while updating it, use something like a Smartphone Charger and the Tomtom USB lead.....

    Note... If you are using MyDrive Connect with the default setting then MDConnect Auto Starts with the PC....
    I have disabled this feature using the MDConnect Setting Menus & created a Desktop shortcut to start MDConnect when required....


    Thanks @YamFazMan,

    I normally use MDConnect just to update the TomTom, since the model (Go 50) has no wi-fi options but only the bluetooth connection.

    Yes, also my MDConnect settings don't allow any Auto Start on the boot of the PC.

    The odd thing is that my problem doesn't happen if I connect to another notebook running Windows 7, that's why I think it's related to Windows 10.

    Thanks in advance for your time.
Sign In or Register to comment.

Who's Online in this Category0