Go Premium 6" is sooo slllooowwww — TomTom Community

Go Premium 6" is sooo slllooowwww

I have a new Go Premium 6" and I can honestly say I love using it, except for the fact that it is so slow to interact with my touch. For example, when I select the "..." button on the lower left that gets you into the menu, it takes about 10 seconds for that menu to come up; from there, it takes about 10 seconds after I select a menu function. It's absolutely unbearable. I use it at work and I don't need to be spending several minutes a day like this. I thought it was due to the WIFI not being connected, but I don't see where you can turn off the wifi. It's connected to my phone via Bluetooth.
Can someone please help me?

Comments

  • DougLapDougLap Posts: 9,151
    Superuser
    Hi @Wilson_Hines

    Try a soft reset. Ie turn the unit on then when ready Press and Hold the On/Off button for 20 seconds plus until you hear the drumroll sound when you then let the button go. The unit will restart.

    This is a useful thing to do after any updates as it tidies the files up.

    Doug
  • Wilson_HinesWilson_Hines Posts: 3 [Apprentice Traveler]
    I'll give it a shot.
  • Wilson_HinesWilson_Hines Posts: 3 [Apprentice Traveler]
    Doug, I hate to admit this, but I'm just getting back in here to tell you this did, in fact, work like a charm. Thanks for the help.
  • DougLapDougLap Posts: 9,151
    Superuser
    Hi @Wilson_Hines

    Glad you are sorted..

    In case this is of interest here are a couple of tips. Firstly check in Settings/System/About to see how much free memory you have on the Internal memory. You should be looking for 400mb minimum as that is used by the operating software whilst running the unit similar to Ram memory. Less than that threatens the speed and operation of the unit and the more there is the better.

    Now if you only have one map on the device then I suggest that you download either Venezuela or Iraq as they are very very small maps or if you only drive in your own State the smallest map containing that area. This means you will have at leats 2 maps on the device and so should you do an update , which you should do one at a time, and there is an issue and as a result lose the map concerned, then you still have a map on the unit so can operate it normally. Then when you lose the map it is a simple matter of using Add a Map to restore the map which will be the latest version. thus avoiding the No Map Found scenario.

    If you have several maps and they are all on the internal memory then adding a Micro SD Class 10 memory card, 16gb or max 32gb, in the Extra memory slot will enable you to add maps to that and so not overloading the internal memory and affecting performance.

    Doug
  • RichtpRichtp Posts: 1 [Apprentice Seeker]
    Hi
    I have a Go Premium 6 which I find incredibly slow, everything takes an age to load, once it’s up and running it’s ok but selecting a destination to searching for an address takes many minutes. Also downloading speed camera updates can take 10 minutes for a 9.98mb file. It’s very glitchy and buggy and will often switch off and reset itself during a route. It’s much slower than my previous Go 540.
Sign In or Register to comment.

Who's Online in this Category0