Still no live traffic — TomTom Community

Still no live traffic

Gary12_jamesGary12_james Posts: 3 [Apprentice Seeker]
Just about had enough of this thing, bought it a week ago for use in my lorry, I'm running in to traffic, road closures, thinking I should have bought Garmin, I have NO LIVE TRAFFIC

Comments

  • DougLapDougLap Posts: 8,666
    Superuser
    Hi @Gary12_james

    Looks like the unit has not completed its setup completely so @VikramK or @lampard should pick this up on Monday when they are back on the forum. They can review the settings for your unit on the TT servers and amend as appropriate. Look back then to see what they have to say.

    Doug
  • Gary12_jamesGary12_james Posts: 3 [Apprentice Seeker]
    Couple of workmates have this 6250 and think it's absolutely great, they talked me into buying one, but for a week I've had no live info sent to it, so not getting rerouted around road closures and accidents, realy frustrating spending all this money on something that don't do its job, I've done factory reset twice, turned my phone off and back on, although it says my LIVE subscription is active it says "Traffic. Service Unavailable, if I click on that it says" we are having trouble accessing TomTom services, please try later...
  • DougLapDougLap Posts: 8,666
    Superuser
    Hi @Gary12_james

    have a look at the information in the following link . your unit is covered by the first list although it is not mentioned.

    https://help.tomtom.com/hc/en-gb/articles/360014530220-TomTom-Traffic-or-LIVE-Services-isn-t-working

    On your phone have you got Personal Hotspot (iPhone) or Bluetooth tethering (Android ) turned on. whenever you are connected to the Device. If you have an iPhone using IOS13 or later then there is no point in involving the MyDrive App during pairing.

    Doug
  • YamFazManYamFazMan Posts: 19,946
    Superusers
    edited May 31
    Hi
    @Gary12_james
    Welcome to the site....
    Are you at home with your GO 6250 Pro connected to a USB port for a power supply + MyDrive connect running on your PC ???
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> About....
    Scroll down to Data Connection... What data connection does the device Report ???
    If the Data Connection is USB.... The USB connection will take priority over the GPRS SIM....
    Try disconnecting the USB lead....
    (Snip) It says "Traffic.... Service Unavailable, if I click on that it says" we are having trouble accessing TomTom services, please try later...
    I find that you Must register the NAV5 (Wi-Fi) devices using Wi-Fi....
    If you try to register the device over USB... You get the error message that you mention in your post....
    _______________________

    Next....
    With your device still disconnected from USB....
    Note... If you need to power the device use something a iPhone Charger & the Tomtom supplied power lead....
    Turn off Wi-Fi....
    Wi-Fi will take priority over the GPRS SIM
    Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on your Connected Wi-Fi
    Tap (Modify) Icon
    Tap (Forget) Icon
    To verify the Wi-Fi is OFF Tap 4Dot (.... Menu) screen top right Wi-Fi logo with X
    70e5b90b-25ce-4fca-994c-e836a17cb9fa.jpg
    To Reconnect to Wi-Fi....
    Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on your chosen Wi-Fi
    Enter your Wi-Fi Password
    Tap Done
    Tap Connect
    _________________________

    Recheck the Data Connection...
    Tap 4Dot (.... Menu) --> Setting --> System --> About…
    Scroll down to Data Connection & GPRS Status....
    What does the device report...???
    Is the GPRS Status... Connected ???

    Stay Safe... ATB YFM
  • kieronkieron Posts: 508
    Superusers
    Hi there Gary12_james -

    GO Professional 6250
    Professional sat nav designed for large vehicles.
    Updates via Wi-Fi®
    Custom truck, coach, van and car routing
    Incl. World Map Updates
    Traffic and Speed Camera Alerts via built-in SIM
    Dedicated truck, van and bus POIs

    As you have been without traffic services for over a week now whilst using the device out on the road, it appears that the built-in SIM has not yet been activated since you registered on the TomTom servers.

    Douglap has advised to wait until Monday which will hopefully resolve your issue.
  • VikramKVikramK Posts: 12,492 Moderator
    Hi @Gary12_james

    Welcome to the community! The device shows active services for the regional countries Australia and New Zealand.
    The device comes with World maps but the services are regional specific only.

    If the device was purchased in Europe then please get in touch with our customer service.

    They might need some additional information before making changes to the account.

    Regards, Vikram
  • skull66skull66 Posts: 47 [Renowned Wayfarer]
    Hi @Gary12_james have you looked at the tmc receiver, here is a link to one I found on Ebay https://www.ebay.co.uk/itm/Genuine-TomTom-Traffic-Receiver-Car-Charger-Micro-USB-Start-Via-RDS-TMC-4UUC5B/333900934316?hash=item4dbe0becac:g:1dUAAOSwyTZUVyqv , I use this with my Premium X in place of the standard power cable
  • SharkyW2SharkyW2 Posts: 2 [Apprentice Traveler]
    I have purchased a TomTom Go Proffesional 6. I keep getting TomTom Services unavailable. I have gone though all of the troubleshooting steps but still have no Live Traffic (device shows Traffic and Speed Cameras active). Additionally, now after a Hard Reset, I cannot connect to My Connect (this was ok prior).

    Can someone help before I put this back in the box and request an RMA.
  • VikramKVikramK Posts: 12,492 Moderator
    edited April 14
    Hi @SharkyW2

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check again..



    Regards, Vikram
  • SharkyW2SharkyW2 Posts: 2 [Apprentice Traveler]
    Vikram,
    Many thanks Obi-Wan, you have restored my faith in the Force.
    Regards,
    Martin
  • JasonclowserJasonclowser Posts: 2 [New Seeker]
    Hi there guys. i am having what would seem as the very same problem and after spending all of my sunday on the phone to a couple of amazon tech heads that tried to sort out my issues i just lost hope after the fourth hour. can you help?
  • DougLapDougLap Posts: 8,666
    Superuser
    Hi @Jasonclowser

    @VikramK or @lampard should pick this up tomorrow and can check your units settings on the TT Servers. Look back here to see what they say.

    Doug
  • VikramKVikramK Posts: 12,492 Moderator
    Hi @Jasonclowser

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram
  • JasonclowserJasonclowser Posts: 2 [New Seeker]
    ISSUE FIXED -

    Amazing, turned it on this morning and as if by magic, all my live updates were back and functioning like they should be. Thank you so much guys, i spent nearly all day on sunday trying to understand what "I had done wrong or set up wrongly" .... Amazon tech should point callers directly to your forum as it would save them about 6 hours of unnecassary conversation that goes absolutley no where.....what a fantastic service you have provided me. Have a great week.

    Kindest regards
    Jason
Sign In or Register to comment.

Who's Online in this Category0