Tomtom Rider 550 becomes stuck on the docking mount — TomTom Community

Tomtom Rider 550 becomes stuck on the docking mount

VonZipperVonZipper Posts: 3 [Apprentice Seeker]
Recently, my Tomtom Rider 550 becomes stuck when placed on the docking mount. This happens every time it is mounted. It's nearly impossible to remove the unit from the mount when this happens. I've had to resort to sliding a thin piece of plastic between the GPs unit and the mount to separate them. I don't see any obstructions or reasons why this is happening now. It had worked flawlessly from 3 years until I installed it last week.


  • TigerRiderTigerRider Posts: 157 [Revered Navigator]
    edited March 13
    @VonZipper, if the mount is like mine you have two flanges on the back of the unit either side on the contacts that mate with the mount as you slide it down onto the mount. Either side on the contacts on the mount are two square pegs that lock into the back of the unit. The pegs are on a sprung plate which sticks up and angles away from the unit when fitted. This plate is sprung loaded and needs pushing back towards the RAM mount to withdraw the pegs.

    To remove the unit from the mount is just a question of pushing the angle bit on the mount away from the unit which in turn pulls the locking pegs out from the holes in the unit. At the same time lift the unit up off the mount.

    Perhaps you've got a load of grot down in the mount stopping movement or perhaps you've got the whole lot upside down.

    I got trapped in an old helmet once because I'd forgotten how the strap lock worked. Was different from my new helmet.
  • VonZipperVonZipper Posts: 3 [Apprentice Seeker]
    edited March 13
    TigerRider, You've described the mount and its operation exactly. The method you describe for removal is how I've been operating it for years. Pushing back on the tap just doesn't release the unit anymore for some reason. I'll have to admit, I've tried to put it on upside down a few times over the years but that's not what's going on here. I've got the mount of the bike now to examine it more closely but I still don't see what's causing its failure to release... Thanks for taking the time to trying to help me out!
  • TigerRiderTigerRider Posts: 157 [Revered Navigator]
    edited March 13
    @VonZipper, have you confirmed the square retaining pegs fully withdraw when you press the tab fully? Do the peg corners show signs of stress?

    Has the tab cracked so is bending rather than withdrawing the pegs fully?

    Maybe also confirm that while pressing the tab fully (and the pegs withdrawn completely) the Rider slides easily on and off the mount.

    If might even be that something is bent or broken but not immediately obvious. The mount is quite simple but any wear could cause two edges to overlap and jam. Check for witness marks or polished bits. Add soft pencil, dry marker pen marks or similar and check for smears after sliding the Rider on/off.

    If I recall the whole mount is held together using small Torx screws and, while fiddly the mount can be taken apart. Has one of the Torx screws pulled out a bit?

    Sorry for the "Granny Suck Eggs" lesson. See also getting my old helmet stuck on. It happens.
  • VonZipperVonZipper Posts: 3 [Apprentice Seeker]
    TigerRider, Thanks for the suggestions. I did look at the operation of the lugs and didn't see anything obviously out of adjustment. The plastic tab looked good overall. At first, I thought the tab may have been fatigued causing it to bend and not fully retract the lugs, but, on closer inspection, it seems fine. The bottom face of the lug didn't seem to fully clear (by about 1/32") the face of the mount when the tab was depressed and I couldn't find any reason for this change.

    I decided to file down the top surface of the lug to ensure it would clear the back of the GPS unit. I also but a slight bevel on the surface of the lower lugs to help with clearance. After reducing and reshaping the lower surface of the lug, it operates normally. The unit locks firmly in place and releases easily as it used to do. I'm still not sure what caused it to not to operate properly in the first place. I suspect that perhaps the lugs became slightly deformed over time somehow but, again, I don't really know! Hopefully, this fix will be a permanent fix! I'll keep an eye on it. We'll see...

  • raesewellraesewell Posts: 176 [Exalted Navigator]
    Try some candle wax on the slides.
Sign In or Register to comment.

Who's Online in this Category0