Lost all maps through TomTom Home — TomTom Community

Lost all maps through TomTom Home

Hi all. My device states 'No maps found'. My last backup was Nov 2020 and states it contains map called Western Europe. When I restore from backup I get the same error - No maps found. The FAQ on this error points me to TomTom Connect. When I install that it states my 'device is not supported'. This is a Rider 2013 with lifetime maps. Thanks in advance.

Best Answer

  • VikramKVikramK Posts: 11,155 Moderator
    Accepted Answer
    Hi @Biker-x
    Welcome to the community! Your RIDER already has an active subscription for Western Europe lifetime maps.
    When you open TomTom HOME with the device connected does it show a map installed?

    If yes, try removing the map from the device > Follow it up with a clean reinstallation of TomTom HOME > See steps on this article- https://help.tomtom.com/hc/en-us/articles/360013901760

    Once done, please check for fresh map updates...

    Regards, Vikram

Answers

  • rider1riderrider1rider Posts: 449 [Supreme Pioneer]
    if the device has lifetime maps then download new map instead of restoring nov 2020 copy.
  • Biker-xBiker-x Posts: 4 [New Seeker]
    Hi and thank for the suggestion. 'Update my Device' offers me only a single GPS fix, no maps listed. 'Purchase maps' offers me three that are 'on my computer' and several to purchase. On installing any of those 'on my computer' the Tom Tom Home software update stalls at 'reorganising files on your device. AM left with 'No maps found' error. Am using a Mac to run TomTom Home. I will try to find a PC to try later in case it's flaky Mac software but any other suggestions welcome. Have owned this device since 2013 and it definitely has lifetime. maps.
  • YamFazManYamFazMan Posts: 18,724
    Superusers
    Hi
    @Biker-x
    Welcome to the site....
    Maybe @VikramK or @lampard the Forum Moderators will pick this up and check/correct your Tomtom Map Account status...

    Stay Safe... ATB YFM
  • Biker-xBiker-x Posts: 4 [New Seeker]
    Thanks very much for the reply YamFazMan - we have one of those in the stable here too! I'll sit tight and hope for a map account status check.
  • VikramKVikramK Posts: 11,155 Moderator
    Accepted Answer
    Hi @Biker-x
    Welcome to the community! Your RIDER already has an active subscription for Western Europe lifetime maps.
    When you open TomTom HOME with the device connected does it show a map installed?

    If yes, try removing the map from the device > Follow it up with a clean reinstallation of TomTom HOME > See steps on this article- https://help.tomtom.com/hc/en-us/articles/360013901760

    Once done, please check for fresh map updates...

    Regards, Vikram
  • Biker-xBiker-x Posts: 4 [New Seeker]
    That solved the issue! Great community. Many thanks for your help folks!
Sign In or Register to comment.

Who's Online in this Category0