I am unable to complete setting up my Go 40 device — TomTom Community

I am unable to complete setting up my Go 40 device

I have been able to connect to my computer and update my device - Great.
Now when I turn it on or connect power to it, the device starts to go through the inital set up process.
I am first asked for my language which I select. Then the device asks me to choose a country but gives no options / list of countries. The all countries button and the "next" button are greyed out and cannot be clicked. The back arrow next to "Choose a country" is the only thing that can be clicked on. This only takes me back to choosing my language.

Does anyone know how I can get passed this please?

Comments

  • YamFazManYamFazMan Posts: 19,429
    Superusers
    Hi
    @DrGadget
    Welcome to the site....
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    Stay Safe... ATB YFM
  • DrGadgetDrGadget Posts: 2 [New Seeker]
    Hi @YamFazMan.
    I tried what you suggested, but this has not made any difference.

    When it turned back on it started to through the set up process again as I had expected it to do, and when I reached the select you country page I couldn't go any further.

    Should I consider the device defunked, and look for a replacement?

    Thanks.
Sign In or Register to comment.

Who's Online in this Category0