Start 60 stuck at "Updating"

MeMyselfAndI7 Registered Users Posts: 2
Apprentice Seeker
Hi there,

I am having a long term problem which is driving me crazy..

So i have a TomTom Start 60 (2013) Model. Couple of years ago i tried to update it's maps on my PC and this is how my dilemma started..
The update somehow damaged my maps (installed on SD Card) so i tried to reinstall the maps with no luck.
Then i tried to put the device into recovery mode then install the maps again and that didn't help either.

I thought maybe installing MyDriveConnect on My MacBook will solve the problem but i was wrong.. the same problem is still there..
Then I thought to remove this device from my account and then adding it again might solve it.. again i was proven wrong and now i can't add the device to my devices.

When i connect my device it is recognized and shows "Updating". MyDriveConnect suggests that i add this device to my devices and that's what i do so MyDriveConnect spins that it's busy adding the device.. i wait days and nothing happens. Sometimes MyDriveConnect crashes and i have to do the process all over again. Some other times (not with the latest update) i used to see a message that i'm not connected to the internet which is not the case.

I tried to contact TomTom Support but they told me to try the update process on some other internet connection which i did but did not help.

p.s: I tried to deactivate my Firewall and Anti-Virus software and that again did not help...

Please help!


  • VikramK
    VikramK Administrators Posts: 14,527
    Hi @MeMyselfAndI7

    Welcome to the community!

    Could you send me the serial number of your device through a private message, please?

    Thanks, Vikram
  • MeMyselfAndI7
    MeMyselfAndI7 Registered Users Posts: 2
    Apprentice Seeker
    So after linking my TomTom device to my account (Thanks to @VikramK) I still have the problem.
    I connect the device and it shows "Updating". I left it for almost two days straight and nothing happens. After that i tried to disconnect it and see if that changed anything but nothing changed. I connected it again and "Updating" was showing again.
    Now i see "TomTom MyDrive Connect" crashing every 10 Mins saying there were an internet-connection problem and i have to click "Retry" and it shows "Updating" again.

    In short: The problem still exists. Please help.