Speed Cameras disappeared after last update

robbar
robbar Registered Users Posts: 1
New Seeker
I haven't updated my Start 40 for a few years and when I recently did so, my existing speed cameras disappeared. The menu shows that they are enabled but they no longer appear on the map when driving. Any help?

Answers

  • YamFazMan
    YamFazMan UKPosts: 21,359
     Superuser
    edited December 2020
    Hi
    @robbar
    Welcome to the site....
    There has been a change in the Speed cam subscriptions... The Tomtom subscriptions now 'Auto Renew' by default....

    See T&C's 4.2 Subscriptions, renewals and Free Trials...
    Here... https://www.tomtom.com/en_gb/legal/terms-and-conditions/#4YourAccountandyoursubscriptions

    Tomtom Speed Cam FAQ….
    See... https://help.tomtom.com/hc/en-gb/articles/360015806999

    Note... If your subscription has expired you will NOT get any Speed cam warning on the device, even the old database is still installed on the device....
    ______________________________

    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    Stay Safe... ATB YFM