Bluetooth connectivity issues for Wi-Fi devices and iOS 13 - Page 20 — TomTom Community

Bluetooth connectivity issues for Wi-Fi devices and iOS 13

11718202223

Comments

  • juresjures Posts: 101 [Sovereign Trailblazer]
    edited September 2020
    When you write the trouth.....
  • juresjures Posts: 101 [Sovereign Trailblazer]
    jures wrote: »
    Admin: I removed the reference to beta. You have signed an NDA!
    I dont know what it means but it looks like someone at tomtom is reading this thread - BUT DOES NOTHING!
    Yes we are pi**ed users!

  • ommoranommoran Posts: 1 [Apprentice Seeker]
    So, on September 24, 2020, Apple released iOS 14.01, with bug fixes.

    MyDrive has not been updated for either iOS or Android in over a year now. Can Tomtom not just abandon Mydrive and give an update to the units that have them set up properly?

    The fix is onerous and ridiculous. Crossposting to Twitter.
  • olaf-karlsenolaf-karlsen Posts: 2 [Apprentice Seeker]
    Hi

    Just a short update. I have a TomTom Go Essential with life traffic data and it seems like everybody else after update my iOS with 12.x to 13.x - the life traffic didn't work normal with BT connection. I tried everything, contacted TomTom support several times. The answer was more or less everytime.. try to restore phone, try to restore navigation unit + bla. bla. bla. So I used maybe around 15-20 hours on this.

    I wrote a note here in this forum and a guy called Doug (Douglas) answered. This was a well know issue etc.

    The problem is that this was also well know for TomTom so why not just say it - why try to make it believe that I'm the only user with an iPhone having the issue and let me spend so many hours with the issue. Therefore I considering to invoice TomTom for some of the hours.

    The good news is that with the iOS update to 14.x - know life traffic data works with BT i.e. one BT connection for handsfree and the other BT connection sharing data. So that the great news.

    But I must admit that I not very happy about how TomTom support handlede this case. Also the closed my tickets even though I stated to them "please do not close this ticket before the issue is solved. Please also consider to put the ticket to high instead of normal importance".

    TomTom Traffic when it works! I love it.
    TomTom Support!!! hmmm, you most be joking.
  • Hanshenrik1Hanshenrik1 Posts: 20 [Legendary Explorer]
    The ios update 14x on my iphone has not solved the problem.I agree that the support from TomTom is worthless.
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Hi

    Just a short update. I have a TomTom Go Essential with life traffic data and it seems like everybody else after update my iOS with 12.x to 13.x - the life traffic didn't work normal with BT connection. I tried everything, contacted TomTom support several times. The answer was more or less everytime.. try to restore phone, try to restore navigation unit + bla. bla. bla. So I used maybe around 15-20 hours on this.

    I wrote a note here in this forum and a guy called Doug (Douglas) answered. This was a well know issue etc.

    The problem is that this was also well know for TomTom so why not just say it - why try to make it believe that I'm the only user with an iPhone having the issue and let me spend so many hours with the issue. Therefore I considering to invoice TomTom for some of the hours.

    The good news is that with the iOS update to 14.x - know life traffic data works with BT i.e. one BT connection for handsfree and the other BT connection sharing data. So that the great news.

    But I must admit that I not very happy about how TomTom support handlede this case. Also the closed my tickets even though I stated to them "please do not close this ticket before the issue is solved. Please also consider to put the ticket to high instead of normal importance".

    TomTom Traffic when it works! I love it.
    TomTom Support!!! hmmm, you most be joking.
    Hi if tou look at my workaround few posts back you will see that data works from the start no mater of Ios (traffic and mydrive). Its just impossible to have data and smart features at the same time because for that you need pairing through tomtom app, and if tou do that you are screwed....until they fix BT interface inside the app we stand no chance of using this features
  • SSinghTTGO500SSinghTTGO500 Posts: 0 [New Seeker]
    I have tried to reset the iphone, the TT device and completed a restore as per directions that I found on TT's support website. Not sure what to do next. Please advise.
  • Hanshenrik1Hanshenrik1 Posts: 20 [Legendary Explorer]
    Sorry , there is nothing you can do.Make an complain to TomTom.Sure it will not solve the problem.
  • AmazingAmazing Posts: 1 [Apprentice Seeker]
    My IPhone Xr, IOS 14.0.1, comments: “If you use “TomTom RIDER 550” this can inflict your wifi- and Bluetooth-connection.” And it does: no My drive and no traffic connection. I have tried all tips & tricks, but nothing works. This feels like € 500 down the drain.
    Please TomTom, update to a functional device quickly!!
  • juresjures Posts: 101 [Sovereign Trailblazer]
    The only solution os workaround few pages back
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Happy Aniversery everyone. Look at first post, its one year. Octobre 2019!
  • TerrieristTerrierist Posts: 4 [Apprentice Seeker]
    A whole year TomTom and no 'proper' fix - only workarounds provided by forum members. DISGRACEFUL... I don't think it's a software issue, probably some sub-standard component in the unit that is incompatible.
  • juresjures Posts: 101 [Sovereign Trailblazer]
    There is a tomtom Rider550 device SW update today - however as I stated many times this will probably have no impact on the issue - as long as TomTom doesnot update the app which is the root cause of the problem (its dual BT channel communication). Last update of app is Nov 2019!
  • Mike-NJ-USAMike-NJ-USA Posts: 2 [New Seeker]
    I think it's time for a lawsuit if they can't figure this out. It's goddamn absurd that for the last few years they haven't addressed this problem. TomTom is being entirely fraudulent in selling us a product that is not what they claim it to be. It can't be that difficult to rewrite a bit of code to make the device work on an iOS device. I have a 400, and I'll be damned if I get a 550 as an upgrade.
  • BeoboiinozBeoboiinoz Posts: 8 [Master Explorer]
    I’m unsure how people are using two Bluetooth connections as I was under the impression that was how one connected using the MyDrive app on the phone. The issue appears to be the MyDrive app locking up and crashing and preventing data coming in by 4G being routed through the app and to the phone by Bluetooth. In other words no internet connection so no traffic and MyDrive features. I create a Wi-Fi hotspot in IOS 14 and connect my GO 620 to it via its inbuilt wifi. I also pair the GO620 to my iPhone by Bluetooth. Hence the GO 620 gets an internet connection via wifi to the phone and the phone is in turn connected to the internet via 4G. My drive and all traffic management features work. Simultaneously the Bluetooth pairing means SIRI hands free and all other phone features work. The only thing that doesn’t work is the MyDrive app on the phone itself and trying to connect to the GO620 through it. Note I haven’t tried connecting through the app since the latest update to IOS14.1 etc but as everything works as described I don’t see the need. Then again I might be missing something as I really only use the GPS on long trips and with COVID-19 lockdowns there haven’t been any of those for nearly a year.

    Cheers.
  • DougLapDougLap Posts: 7,745
    Superuser
    Hi @Beoboiinoz

    Regarding you reference to the Personal Hotspot you do not need to actually connect it by logging into the TT units Wifi. If you just turn your Personal Hotspot On, but not log into it, and then connect your GO620 to Bluetooth as you would with most pieces of equipment the iPhone and the TT unit will connect and the Traffic and handsfree will work. At no time during this process do you need the My Drive App open on the phone nor do you log into the units Wifi with the Personal Hotspots Password.

    Doing as above will mean that messaging will not work which is what the My Drive Apps involvement was facilitating. Once you have connected as I describe should you turn the Personal Hotspot function Off on the phone the Bluetooth connection will be lost.

    Doug
  • Nigel ANigel A Posts: 121 [Renowned Trailblazer]
    I was impressed by the 400 I borrowed, so I bought a much upgraded 550......... What a bad move !!!! Ended up with a disabled 400 !!!! The workaround does give me traffic, but the phone notifications etc are a forget it. I find it very distasteful that Tomtom are still pushing the Rider 550 onto bikers when they know full well that it doesn't work. The fact that Tyre was not compatible, and most interconnection needs to be done with a sd card. Would have been a great device if it was sold and manufactured by someone with even a basic knowledge of computers and sat navs. and sorted it out.
  • johnsondvrjohnsondvr Posts: 29 [Prominent Wayfarer]
    Moved to Garmin Zumo XT a few months and, whilst I miss some of the sync aspects of the TomTom Rider 550, the XT connects without problems and does what it advertises as doing - so glad to leave the problematic Rider 550 behind. Also so frustrating that TomTom appear to have no priority to rectify the issue. Sounds like a hardware problem to me and so glad I changed to the competition. I stayed on the community to see if there was a fix forthcoming; alas, there does not appear to be a fix.
  • bonsipogibonsipogi Posts: 228 [Exalted Navigator]
    I think it's time for a lawsuit if they can't figure this out. It's goddamn absurd that for the last few years they haven't addressed this problem. TomTom is being entirely fraudulent in selling us a product that is not what they claim it to be. It can't be that difficult to rewrite a bit of code to make the device work on an iOS device. I have a 400, and I'll be damned if I get a 550 as an upgrade.

    Hello Mike,

    did you updated your 400 to the new Nav4 firmware? If yes, is your BT-connection with your iPhone still working without any problems?
  • Mike-NJ-USAMike-NJ-USA Posts: 2 [New Seeker]
    bonsipogi wrote: »
    I think it's time for a lawsuit if they can't figure this out. It's goddamn absurd that for the last few years they haven't addressed this problem. TomTom is being entirely fraudulent in selling us a product that is not what they claim it to be. It can't be that difficult to rewrite a bit of code to make the device work on an iOS device. I have a 400, and I'll be damned if I get a 550 as an upgrade.

    Hello Mike,

    did you updated your 400 to the new Nav4 firmware? If yes, is your BT-connection with your iPhone still working without any problems?

    Hello Bonsipgi,

    In my about settings on the 400 the Application Version is 20.100.0001.311 (0) (10/13/2020)

    So apparently yes, I have Nav4 firmware. And no, it does connect to my iPhone, now with iOS 14 running, but it does not stay connected. And when I try to open the my drive app, I just get a black screen. After trying to hook up the device to my phone, MyDrive continued to give me a black screen until I deleted it and re-installed it.

    So, yes, latest FW for the 400, and the latest 1 year old app for my phone. Still, no love between them.

    I like the MyDrive website for planning rides, but I don't bring a computer with me on rides if I need to make a change. It's frustrating that when I hit a detour due to a road closure, the 400 becomes useless as it just wants me to keep going back to the tack and will not re-route. I don't know if that's because it doesn't hook up to the phone, or because it's just not sophisticated enough to ever figure.

    My experience with Garmin has be terrible, so I'm about to pitch the whole idea of having a GPS unit at all. I'm seriously thinking of getting a BeeLine unit that relies on my phone instead. I just worry how it will work in area's that don't have cell phone coverage.

    As you are an Exalted Navigator, any advice from you would be welcome. Seriously.

    Thanks,
    Mike
  • DS3DS3 Posts: 1 [Apprentice Seeker]
    My GO 620 (wifi updates) stopped pairing with my iPhone. I found help that told me to update software on both. I am up to date on both devices but GPS will still not pair to iPhone? tried with different iPhone but got same result. What else can I do to resolve this issue? This is my 5th TomTom GPS and I have been thrilled with each of them, until now. Bluetooth fast cycles between connecting, connected, and unable to connect. Any help would be appreciated.
  • bonsipogibonsipogi Posts: 228 [Exalted Navigator]
    I still have the 18.xxx firmware on my 450 andthere are no problems with my iPhone 14.2!!!

    That's Why I asked my question BEFORE I consider to update to the 20.xxx firmware.

    My conclussion is:

    For me it is better to have old maps installated instead of loosing the BT-Connection! So I do not update!
  • juresjures Posts: 101 [Sovereign Trailblazer]
    I suggest everyone leaves a review on appstore for the Mydrive app with lowest score and warning TO STAY AWAY from Tomtom products and this app. I just did it
  • PaoloVPaoloV Posts: 1 [New Seeker]
    Nothing to do... the pairing is not good with or without mydrive. Only hotspot😭
  • 2019TracerGT2019TracerGT Posts: 1 [Apprentice Seeker]
    I too have been suffering the connectivity issues to my iPhone 8 ever since the release of iOS 13. My TomTom 550 worked flawlessly prior to that - serving up live traffic, notifications, texts, etc.

    I've also spent many hours on the phone with support and in following their instructions to reset my device, my phone, my account, etc. I've gone through those reset steps so many times that I've lost count. Also, as many others have noted, when the reset works, it doesn't last. I've found that the first time that my TomTom goes to sleep or loses connectivity to my phone, it will not reestablish it, putting me back to square one.

    There seems to be an assumption that the issue is with iOS, as the issue only popped up (apparently) with iOS 13. That was my assumption/belief as well. That is, until last month when I purchased a new headset/intercom.

    I have a Cardo PackTalk Bold now, which I paired with the TomTom when I got it. Just as with my iPhone, it worked great until either the headset or Rider went to sleep or out of range and then it refused to reestablish the connection without going through the pairing process again. I've tested this multiple times with the exact same result. The TomTom just refuses to remember any Bluetooth connections!

    It is apparent that the device itself (TomTom Rider) needs an OS or firmware update to resolve the problem. In addition, I agree with everyone else who have called out that it's criminal that TomTom haven't released an app update in over a year!

    PLEASE HELP US!
Sign In or Register to comment.

Who's Online in this Category0